aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-gvm
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-01-06 08:24:12 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-01-06 08:24:12 +0000
commit21640666a6101ed83263201cb885fcdca4a58ad3 (patch)
tree58b2d980f3b36d8b622149e9c0f52199761a0729 /security/py-python-gvm
parent3f121a3e4f7e79bc9e0400c14283c259c6fa446a (diff)
downloadports-21640666a6101ed83263201cb885fcdca4a58ad3.tar.gz
ports-21640666a6101ed83263201cb885fcdca4a58ad3.zip
Notes
Diffstat (limited to 'security/py-python-gvm')
-rw-r--r--security/py-python-gvm/Makefile19
-rw-r--r--security/py-python-gvm/distinfo3
-rw-r--r--security/py-python-gvm/files/patch-setup.py34
-rw-r--r--security/py-python-gvm/pkg-descr9
4 files changed, 65 insertions, 0 deletions
diff --git a/security/py-python-gvm/Makefile b/security/py-python-gvm/Makefile
new file mode 100644
index 000000000000..1f5177eccdc0
--- /dev/null
+++ b/security/py-python-gvm/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= python-gvm
+DISTVERSION= 20.12.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= The Greenbone Vulnerability Management Python API library
+
+LICENSE= GPLv3+
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-python-gvm/distinfo b/security/py-python-gvm/distinfo
new file mode 100644
index 000000000000..fcd9fce1106c
--- /dev/null
+++ b/security/py-python-gvm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609778854
+SHA256 (python-gvm-20.12.1.tar.gz) = cef82bc78c64dbede980645461130f65c2c6a3a31e221f27620cb6a85632386b
+SIZE (python-gvm-20.12.1.tar.gz) = 179355
diff --git a/security/py-python-gvm/files/patch-setup.py b/security/py-python-gvm/files/patch-setup.py
new file mode 100644
index 000000000000..a850c3784307
--- /dev/null
+++ b/security/py-python-gvm/files/patch-setup.py
@@ -0,0 +1,34 @@
+--- setup.py.orig 2021-01-04 18:38:41.394413000 -0500
++++ setup.py 2021-01-04 18:38:57.320954000 -0500
+@@ -8,30 +8,7 @@
+ 'gvm.protocols.gmpv214',
+ 'gvm.protocols.gmpv7',
+ 'gvm.protocols.gmpv8',
+- 'gvm.protocols.gmpv9',
+- 'tests',
+- 'tests.connections',
+- 'tests.protocols',
+- 'tests.protocols.gmp',
+- 'tests.protocols.gmpv208',
+- 'tests.protocols.gmpv208.testcmds',
+- 'tests.protocols.gmpv208.testtypes',
+- 'tests.protocols.gmpv214',
+- 'tests.protocols.gmpv214.testcmds',
+- 'tests.protocols.gmpv214.testtypes',
+- 'tests.protocols.gmpv7',
+- 'tests.protocols.gmpv7.testcmds',
+- 'tests.protocols.gmpv7.testtypes',
+- 'tests.protocols.gmpv8',
+- 'tests.protocols.gmpv8.testcmds',
+- 'tests.protocols.gmpv8.testtypes',
+- 'tests.protocols.gmpv9',
+- 'tests.protocols.gmpv9.testcmds',
+- 'tests.protocols.gmpv9.testtypes',
+- 'tests.protocols.osp',
+- 'tests.transforms',
+- 'tests.utils',
+- 'tests.xml']
++ 'gvm.protocols.gmpv9']
+
+ package_data = \
+ {'': ['*']}
diff --git a/security/py-python-gvm/pkg-descr b/security/py-python-gvm/pkg-descr
new file mode 100644
index 000000000000..cabb0edc1574
--- /dev/null
+++ b/security/py-python-gvm/pkg-descr
@@ -0,0 +1,9 @@
+The Greenbone Vulnerability Management Python API library (python-gvm) is a
+collection of APIs that help with remote controlling a Greenbone Security
+Manager (GSM) appliance and its underlying Greenbone Vulnerability Manager
+(GVM).
+
+The library essentially abstracts accessing the communication protocols
+Greenbone Management Protocol (GMP) and Open Scanner Protocol (OSP)
+
+WWW: https://github.com/greenbone/python-gvm