aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-registry
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-10-20 18:29:53 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-10-20 18:29:53 +0000
commitfe525125e463c6372fcb3c42f74c90a075ed81b5 (patch)
treefaf397bd3cfc549a619c73348e6eb4b9d1eec792 /security/py-python-registry
parent2a59eb0a57324b1169c6e70d8b21d7a169cd9b2c (diff)
downloadports-fe525125e463c6372fcb3c42f74c90a075ed81b5.tar.gz
ports-fe525125e463c6372fcb3c42f74c90a075ed81b5.zip
Notes
Diffstat (limited to 'security/py-python-registry')
-rw-r--r--security/py-python-registry/Makefile25
-rw-r--r--security/py-python-registry/distinfo4
2 files changed, 15 insertions, 14 deletions
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
index f6ab3877df1d..3dc631855993 100644
--- a/security/py-python-registry/Makefile
+++ b/security/py-python-registry/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= python-registry
-PORTVERSION= 0.2.7
+PORTVERSION= 1.0.0
CATEGORIES= security devel python
MASTER_SITES= GH \
LOCAL/antoine
@@ -16,31 +16,32 @@ LICENSE= AL2
USE_GITHUB= yes
GH_ACCOUNT= williballenthin
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= ca12109
+GH_COMMIT= 1d16db8
-USE_PYTHON= -2.7
+USES= shebangfix
+SHEBANG_FILES= samples/*.py
+python_OLD_CMD= .*
+python_CMD= ${PYTHON_CMD}
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYTHON_PY3K_PLIST_HACK= yes
OPTIONS_DEFINE= DOCS EXAMPLES
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
-post-patch:
- ${REINPLACE_CMD} 's|0.2.6|${PORTVERSION}|' ${WRKSRC}/Registry/__init__.py
- ${REINPLACE_CMD} '1s|.*|#!${PYTHON_CMD}|' ${WRKSRC}/samples/*.py
-
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/documentation/* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG.TXT ${WRKSRC}/CONTRIBUTORS.TXT ${WRKSRC}/README.txt \
+ ${WRKSRC}/documentation/* ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/samples/*.py ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/samples/*.py ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/security/py-python-registry/distinfo b/security/py-python-registry/distinfo
index 33611ea22e96..c7f8931c8f2b 100644
--- a/security/py-python-registry/distinfo
+++ b/security/py-python-registry/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python-registry-0.2.7.tar.gz) = c5f17f05970b6901b54536b255b2a4f4d962a1cc64aadba8279266a9bec66e59
-SIZE (python-registry-0.2.7.tar.gz) = 136060
+SHA256 (python-registry-1.0.0.tar.gz) = 6924ba21b92928bc7b6f25e17ce6ad46c82e7a0d6b60506ca6a8a2c380adef5d
+SIZE (python-registry-1.0.0.tar.gz) = 136542