aboutsummaryrefslogtreecommitdiff
path: root/security/py-rekall/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-09-10 21:21:48 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-09-10 21:21:48 +0000
commit9fdd1c5d593c021d10dfd42218c70247041fe1b7 (patch)
treeefa1bade1cb56f7e85e747c3461cda73c578cd3d /security/py-rekall/Makefile
parent5da1ef3f7e41d5d4dd4c9364c99e684f75cbbb08 (diff)
downloadports-9fdd1c5d593c021d10dfd42218c70247041fe1b7.tar.gz
ports-9fdd1c5d593c021d10dfd42218c70247041fe1b7.zip
Notes
Diffstat (limited to 'security/py-rekall/Makefile')
-rw-r--r--security/py-rekall/Makefile38
1 files changed, 4 insertions, 34 deletions
diff --git a/security/py-rekall/Makefile b/security/py-rekall/Makefile
index 336308a57175..4cdab81cbd9b 100644
--- a/security/py-rekall/Makefile
+++ b/security/py-rekall/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rekall
-PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTVERSION= 1.4.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,40 +11,11 @@ MAINTAINER= antoine@FreeBSD.org
COMMENT= Memory forensics analysis framework
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= cabextract:${PORTSDIR}/archivers/cabextract \
- ${PYTHON_PKGNAMEPREFIX}acora>=1.8:${PORTSDIR}/textproc/py-acora \
- ${PYTHON_PKGNAMEPREFIX}PyAFF4>=0.12:${PORTSDIR}/security/py-pyaff4 \
- ${PYTHON_PKGNAMEPREFIX}capstone>=0:${PORTSDIR}/devel/py-capstone \
- ${PYTHON_PKGNAMEPREFIX}codegen>=1.0:${PORTSDIR}/devel/py-codegen \
- ${PYTHON_PKGNAMEPREFIX}distorm>=0:${PORTSDIR}/devel/py-distorm \
- ${PYTHON_PKGNAMEPREFIX}Flask>=0.10.1:${PORTSDIR}/www/py-flask \
- ${PYTHON_PKGNAMEPREFIX}Flask-Sockets>=0:${PORTSDIR}/www/py-flask-sockets \
- ${PYTHON_PKGNAMEPREFIX}gevent>=1.0.1:${PORTSDIR}/devel/py-gevent \
- ${PYTHON_PKGNAMEPREFIX}gevent-websocket>=0.9.3:${PORTSDIR}/www/py-gevent-websocket \
- ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.0.4:${PORTSDIR}/devel/py-intervaltree \
- ${PYTHON_PKGNAMEPREFIX}ipython>=2.0.0:${PORTSDIR}/devel/ipython \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.3.1:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.22:${PORTSDIR}/devel/py-pyelftools \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2012:${PORTSDIR}/devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}yaml>=2.10:${PORTSDIR}/devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}yara>=0:${PORTSDIR}/security/py-yara
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}rekall-core>=1.4.0:${PORTSDIR}/security/py-rekall-core \
+ ${PYTHON_PKGNAMEPREFIX}rekall_gui>=1.4.0:${PORTSDIR}/security/py-rekall_gui
-USES= python:2 shebangfix
-SHEBANG_FILES= manuskript/static/bower_components/bootstrap/test-infra/uncached-npm-install.sh
+USES= python:2
USE_PYTHON= distutils autoplist
-PORTDOCS= CREDITS.txt LEGAL.txt README.md
-
-OPTIONS_DEFINE= DOCS
-
-post-patch:
- @${CHMOD} -R a+rX ${WRKSRC}
- @${REINPLACE_CMD} '/argparse/d ; /ipython/s/3.0.0/2.0.0/' ${WRKSRC}/setup.py
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>