aboutsummaryrefslogtreecommitdiff
path: root/security/py-rekall_lib/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-05-24 17:20:22 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-05-24 17:20:22 +0000
commit9e4b89019e474c0d437b68b16137e88af0c89cc7 (patch)
tree40ca7252e9c8862b87dfae87eea58c83e4caf37c /security/py-rekall_lib/Makefile
parentd5f208d9ae56fb56f42d59b2d2dcc88da045942f (diff)
downloadports-9e4b89019e474c0d437b68b16137e88af0c89cc7.tar.gz
ports-9e4b89019e474c0d437b68b16137e88af0c89cc7.zip
Notes
Diffstat (limited to 'security/py-rekall_lib/Makefile')
-rw-r--r--security/py-rekall_lib/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/py-rekall_lib/Makefile b/security/py-rekall_lib/Makefile
new file mode 100644
index 000000000000..f0462f3c5d2a
--- /dev/null
+++ b/security/py-rekall_lib/Makefile
@@ -0,0 +1,25 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= rekall_lib
+DISTVERSION= 1.7.2rc1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Rekall Support Libraries
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>=0.10.0:devel/py-arrow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.5.7:devel/py-sortedcontainers@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>=0:security/py-pycryptodome@${PY_FLAVOR}
+
+NO_ARCH= yes
+USES= python zip
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>