aboutsummaryrefslogtreecommitdiff
path: root/security/py-requests-credssp/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-09 19:06:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-09 19:06:37 +0000
commit4bf16ac2fa4fccea470bc269db8ca864c1c481f8 (patch)
treef6c0f1afeac373a1fc69fadbd574842e9f7806f2 /security/py-requests-credssp/Makefile
parent9bb11ffb67f30e4a56f504b09b992e1c26e050ee (diff)
downloadports-4bf16ac2fa4fccea470bc269db8ca864c1c481f8.tar.gz
ports-4bf16ac2fa4fccea470bc269db8ca864c1c481f8.zip
Notes
Diffstat (limited to 'security/py-requests-credssp/Makefile')
-rw-r--r--security/py-requests-credssp/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/py-requests-credssp/Makefile b/security/py-requests-credssp/Makefile
index 1eb8fa738a95..29aff1734b40 100644
--- a/security/py-requests-credssp/Makefile
+++ b/security/py-requests-credssp/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= requests-credssp
-PORTVERSION= 0.1.0
+PORTVERSION= 1.0.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -9,14 +9,18 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rozhuk.im@gmail.com
COMMENT= Authentication handler for using CredSSP with Python Requests
-LICENSE= ISCL
+LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ntlm-auth>=0:security/py-ntlm-auth@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ntlm-auth>=0:security/py-ntlm-auth@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.3.1:devel/py-pyasn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
-NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
.include <bsd.port.mk>