aboutsummaryrefslogtreecommitdiff
path: root/security/py-rijndael
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-23 09:03:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-23 09:03:45 +0000
commitca7f19c4af3a845b34a823aa52a9274131df284b (patch)
tree7c5125c32d60acbf46ec8b5c682ee1f40336396c /security/py-rijndael
parent67e78b4f978fa06ada1c99ceae5f842a76f4909b (diff)
downloadports-ca7f19c4af3a845b34a823aa52a9274131df284b.tar.gz
ports-ca7f19c4af3a845b34a823aa52a9274131df284b.zip
Notes
Diffstat (limited to 'security/py-rijndael')
-rw-r--r--security/py-rijndael/Makefile33
-rw-r--r--security/py-rijndael/distinfo1
-rw-r--r--security/py-rijndael/pkg-comment1
-rw-r--r--security/py-rijndael/pkg-descr5
-rw-r--r--security/py-rijndael/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/security/py-rijndael/Makefile b/security/py-rijndael/Makefile
new file mode 100644
index 000000000000..9861bc2a73b0
--- /dev/null
+++ b/security/py-rijndael/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: py-rijndael
+# Date created: Jul 23, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rijndael
+PORTVERSION= 1.1
+CATEGORIES= security python
+MASTER_SITES= http://bluesine.com/archives/software/python-mods/rijndael/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyRijndael-${PORTVERSION}.py
+EXTRACT_SUFX= .gz
+
+MAINTAINER= ports@FreeBSD.org
+
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+
+post-extract:
+ @${MV} ${WRKSRC}/${DISTNAME} ${WRKSRC}/pyRijndael.py
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -c 'import pyRijndael'
+ @cd ${WRKSRC} && ${PYTHON_CMD} -O -c 'import pyRijndael'
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/pyRijndael.* ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/security/py-rijndael/distinfo b/security/py-rijndael/distinfo
new file mode 100644
index 000000000000..438ea7dcca30
--- /dev/null
+++ b/security/py-rijndael/distinfo
@@ -0,0 +1 @@
+MD5 (pyRijndael-1.1.py.gz) = aa0053ffecbddb1fbfc685ae467663e5
diff --git a/security/py-rijndael/pkg-comment b/security/py-rijndael/pkg-comment
new file mode 100644
index 000000000000..069f6bb5a48d
--- /dev/null
+++ b/security/py-rijndael/pkg-comment
@@ -0,0 +1 @@
+A pure python implementation of the Rijndael encryption algorithm
diff --git a/security/py-rijndael/pkg-descr b/security/py-rijndael/pkg-descr
new file mode 100644
index 000000000000..92a7651bb6d9
--- /dev/null
+++ b/security/py-rijndael/pkg-descr
@@ -0,0 +1,5 @@
+A pure python implementation of the Rijndael encryption algorithm. Useful for
+quick string encryption in python programs but probably is not fast enough for
+anything too big.
+
+WWW: http://bluesine.com/archives/software/python-mods/rijndael/
diff --git a/security/py-rijndael/pkg-plist b/security/py-rijndael/pkg-plist
new file mode 100644
index 000000000000..9a4262458bd1
--- /dev/null
+++ b/security/py-rijndael/pkg-plist
@@ -0,0 +1,3 @@
+lib/%%PYTHON_VERSION%%/site-packages/pyRijndael.py
+lib/%%PYTHON_VERSION%%/site-packages/pyRijndael.pyc
+lib/%%PYTHON_VERSION%%/site-packages/pyRijndael.pyo