aboutsummaryrefslogtreecommitdiff
path: root/security/py-rsa
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-09-26 14:40:36 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-09-26 14:40:36 +0000
commitbc869da5ee19dcd16773699272e4660aced89fff (patch)
tree4351da57b4ba51c9822229c433f5a0e28068e8d9 /security/py-rsa
parent085c1a3bcbfc1a6099ba50f04af34d71a896aa87 (diff)
Notes
Diffstat (limited to 'security/py-rsa')
-rw-r--r--security/py-rsa/Makefile14
-rw-r--r--security/py-rsa/distinfo4
-rw-r--r--security/py-rsa/files/patch-setup.py16
-rw-r--r--security/py-rsa/pkg-descr2
-rw-r--r--security/py-rsa/pkg-plist3
5 files changed, 19 insertions, 20 deletions
diff --git a/security/py-rsa/Makefile b/security/py-rsa/Makefile
index ae5d8e95ca78..c3db3c5c0104 100644
--- a/security/py-rsa/Makefile
+++ b/security/py-rsa/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rsa
-PORTVERSION= 3.1.1
+PORTVERSION= 3.1.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +12,16 @@ COMMENT= Pure-Python RSA implementation
LICENSE= AL2
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.3:${PORTSDIR}/devel/py-asn1
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.3:${PORTSDIR}/devel/py-asn1
+TEST_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2 \
+ ${RUN_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS=easy_install
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
NO_STAGE= yes
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} run_tests.py
+
.include <bsd.port.mk>
diff --git a/security/py-rsa/distinfo b/security/py-rsa/distinfo
index ed20272d678e..b6db5d0a2b78 100644
--- a/security/py-rsa/distinfo
+++ b/security/py-rsa/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rsa-3.1.1.tar.gz) = ed83fe80602077bcbf91d14e41558c751d76527c7b88d44394e1e2900fddb7ba
-SIZE (rsa-3.1.1.tar.gz) = 37584
+SHA256 (rsa-3.1.2.tar.gz) = 66eb8752a1de9b92d7679ea0e1556cf2e4a155161d0024e97e06999041e35f58
+SIZE (rsa-3.1.2.tar.gz) = 35237
diff --git a/security/py-rsa/files/patch-setup.py b/security/py-rsa/files/patch-setup.py
index 47d240121a6c..4bfa12e73943 100644
--- a/security/py-rsa/files/patch-setup.py
+++ b/security/py-rsa/files/patch-setup.py
@@ -1,16 +1,6 @@
---- ./setup.py.orig 2012-06-19 00:14:17.000000000 +1000
-+++ ./setup.py 2012-06-29 17:34:36.000000000 +1000
-@@ -1,9 +1,5 @@
- #!/usr/bin/env python
-
--# Ensure that a reasonably recent version of 'distribute' is installed.
--from distribute_setup import use_setuptools
--use_setuptools('0.6.10')
--
- from setuptools import setup
-
- import rsa
-@@ -41,5 +37,5 @@
+--- ./setup.py.orig 2013-09-26 22:34:41.233363167 +1000
++++ ./setup.py 2013-09-26 22:34:50.192985862 +1000
+@@ -42,5 +42,5 @@
'pyrsa-encrypt-bigfile = rsa.cli:encrypt_bigfile',
'pyrsa-decrypt-bigfile = rsa.cli:decrypt_bigfile',
]},
diff --git a/security/py-rsa/pkg-descr b/security/py-rsa/pkg-descr
index 09bcba45e15e..0c150504461b 100644
--- a/security/py-rsa/pkg-descr
+++ b/security/py-rsa/pkg-descr
@@ -2,4 +2,4 @@ Python-RSA is a pure-Python RSA implementation. It supports encryption and
decryption, signing and verifying signatures, and key generation according to
PKCS#1 version 1.5.
-WWW: http://stuvel.eu/rsa
+WWW: http://stuvel.eu/rsa
diff --git a/security/py-rsa/pkg-plist b/security/py-rsa/pkg-plist
index 90335fc9ee32..5de6ba2c0b17 100644
--- a/security/py-rsa/pkg-plist
+++ b/security/py-rsa/pkg-plist
@@ -26,6 +26,9 @@ bin/pyrsa-decrypt-bigfile
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/_version200.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/_version200.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/_version200.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/asn1.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/asn1.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/asn1.pyo
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/bigfile.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/bigfile.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/rsa/bigfile.pyo