aboutsummaryrefslogtreecommitdiff
path: root/security/py-stix/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-01-22 13:41:35 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-01-22 13:41:35 +0000
commit31c8b9b87eceddf28ccbc8fbce3bfcc3efe53bf7 (patch)
treea0b95eebc50a6e9bb2d2075aee8e2432aa64edaf /security/py-stix/Makefile
parented08712f9db1c4a81c79d3ddb16ced7e1a360c3e (diff)
downloadports-31c8b9b87eceddf28ccbc8fbce3bfcc3efe53bf7.tar.gz
ports-31c8b9b87eceddf28ccbc8fbce3bfcc3efe53bf7.zip
Notes
Diffstat (limited to 'security/py-stix/Makefile')
-rw-r--r--security/py-stix/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/security/py-stix/Makefile b/security/py-stix/Makefile
index 00b607c957b8..4b4d2a6645dd 100644
--- a/security/py-stix/Makefile
+++ b/security/py-stix/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= stix
-PORTVERSION= 1.1.1.7
+PORTVERSION= 1.2.0.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,12 +15,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}lxml>=2.3:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}cybox>=2.1.0.11:security/py-cybox
+ ${PYTHON_PKGNAMEPREFIX}cybox>=2.1.0.11:security/py-cybox \
+ ${PYTHON_PKGNAMEPREFIX}mixbox>=1.0.1:security/py-mixbox
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose \
- ${PYTHON_PKGNAMEPREFIX}maec>=4.1.0.12:security/py-maec
+ ${PYTHON_PKGNAMEPREFIX}maec>=4.1.0.13:security/py-maec
NO_ARCH= yes
-USES= python:2.7
+USES= python
USE_PYTHON= distutils autoplist
PORTDOCS= README.rst
@@ -28,11 +29,11 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-post-install-DOCS-on:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-post-install-EXAMPLES-on:
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}