aboutsummaryrefslogtreecommitdiff
path: root/security/py-twofish
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-30 11:12:10 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-30 11:12:10 +0000
commit9eea562879466d1c767e58ff0e4db5964799c3f1 (patch)
tree3d4ec47e142188235c0fef963db1b9fa7f870a87 /security/py-twofish
parent06b0037ea8313c7ceb0b708526c11077618e009f (diff)
security/py-twofish: support staging and restrict to python 2.x
Notes
Notes: svn path=/head/; revision=338085
Diffstat (limited to 'security/py-twofish')
-rw-r--r--security/py-twofish/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/security/py-twofish/Makefile b/security/py-twofish/Makefile
index 43bdae2cdbf7..c937af3cf983 100644
--- a/security/py-twofish/Makefile
+++ b/security/py-twofish/Makefile
@@ -12,17 +12,15 @@ DISTNAME= twofishmodule-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Twofish cryptographic module for Python
-USE_PYTHON= yes
+USE_PYTHON= 2
GNU_CONFIGURE= yes
CFLAGS+= -fPIC
-NO_STAGE= yes
do-install:
- ${INSTALL_DATA} ${WRKSRC}/_twofish.so ${PYTHON_SITELIBDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/_twofish.so ${STAGEDIR}${PYTHON_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${STAGEDIR}${PYTHON_SITELIBDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>