aboutsummaryrefslogtreecommitdiff
path: root/security/py-vici
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-01-31 16:26:26 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-01-31 16:26:26 +0000
commit934fb54861552a0bb88425e66d0604f72d6a2b95 (patch)
treed0943c7620cb3ce18dbd3e72aa00ffda9d81b2b5 /security/py-vici
parent3ff4e3c4ab44336a436f15a90613b5d5b8d116b2 (diff)
downloadports-934fb54861552a0bb88425e66d0604f72d6a2b95.tar.gz
ports-934fb54861552a0bb88425e66d0604f72d6a2b95.zip
New port: security/py-vici: Native Python interface for strongSwan's VICI protocol
The strongSwan VICI protocol allows external applications to monitor, configure and control the IKE daemon charon. This Python package provides a native client side implementation of the VICI protocol, well suited to script automated tasks in a reliable way. WWW: https://pypi.org/project/vici/ Event: Brussels DevSummit 2020 PR: 243270 Submitted by: Dries Michiels <driesm.michiels@gmail.com>
Notes
Notes: svn path=/head/; revision=524726
Diffstat (limited to 'security/py-vici')
-rw-r--r--security/py-vici/Makefile27
-rw-r--r--security/py-vici/distinfo3
-rw-r--r--security/py-vici/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/security/py-vici/Makefile b/security/py-vici/Makefile
new file mode 100644
index 000000000000..bacf25144854
--- /dev/null
+++ b/security/py-vici/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= vici
+DISTVERSION= 5.8.2
+CATEGORIES= security net-vpn python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= driesm.michiels@gmail.com
+COMMENT= Native Python interface for strongSwan's VICI protocol
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycodestyle>0:devel/py-pycodestyle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test: # skip non installed python versions in the tests (because flavors)
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m tox --skip-missing-interpreters
+
+.include <bsd.port.mk>
diff --git a/security/py-vici/distinfo b/security/py-vici/distinfo
new file mode 100644
index 000000000000..2b7cf1289748
--- /dev/null
+++ b/security/py-vici/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579026725
+SHA256 (vici-5.8.2.tar.gz) = d642573afa07005914e5449486e53a5efa3419caf8cbd4491bdb62fc45f8b700
+SIZE (vici-5.8.2.tar.gz) = 9615
diff --git a/security/py-vici/pkg-descr b/security/py-vici/pkg-descr
new file mode 100644
index 000000000000..f52d52c66007
--- /dev/null
+++ b/security/py-vici/pkg-descr
@@ -0,0 +1,6 @@
+The strongSwan VICI protocol allows external applications to
+monitor, configure and control the IKE daemon charon.
+This Python package provides a native client side implementation
+of the VICI protocol, well suited to script automated tasks in a reliable way.
+
+WWW: https://pypi.org/project/vici/