aboutsummaryrefslogtreecommitdiff
path: root/security/py-volatility
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-01-05 19:18:14 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-01-05 19:18:14 +0000
commitfddf4837959d389ee56f9050be4d01690c240469 (patch)
tree01b3ccc6d51c99e71b3f13e0e1c78fdb4f6733bd /security/py-volatility
parente329265033eb36cd57eecf2d5846a14db02b28cd (diff)
downloadports-fddf4837959d389ee56f9050be4d01690c240469.tar.gz
ports-fddf4837959d389ee56f9050be4d01690c240469.zip
Notes
Diffstat (limited to 'security/py-volatility')
-rw-r--r--security/py-volatility/Makefile8
-rw-r--r--security/py-volatility/distinfo5
-rw-r--r--security/py-volatility/files/patch-setup.py14
-rw-r--r--security/py-volatility/files/patch-volatility_plugins_malware_psxview.py2
-rw-r--r--security/py-volatility/files/patch-volatility_renderers_xlsx.py2
5 files changed, 9 insertions, 22 deletions
diff --git a/security/py-volatility/Makefile b/security/py-volatility/Makefile
index ea74caacae66..83c0b6d7b9f3 100644
--- a/security/py-volatility/Makefile
+++ b/security/py-volatility/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= volatility
-PORTVERSION= 2.5
-PORTREVISION= 1
+PORTVERSION= 2.6
CATEGORIES= security python
MASTER_SITES= http://downloads.volatilityfoundation.org/releases/${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,7 +20,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}yara>=0:security/py-yara \
${PYTHON_PKGNAMEPREFIX}openpyxl>=0:textproc/py-openpyxl
-USES= python:2 zip
+NO_ARCH= yes
+USES= python:2.7 zip
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= DOCS
@@ -35,7 +35,7 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
PYDISTUTILS_INSTALLARGS+=--install-data ${DATADIR}
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/security/py-volatility/distinfo b/security/py-volatility/distinfo
index cc02124442bf..16147b25e678 100644
--- a/security/py-volatility/distinfo
+++ b/security/py-volatility/distinfo
@@ -1,2 +1,3 @@
-SHA256 (volatility-2.5.zip) = b90dfd18b6a99e1b35ef0f92f28422cca03bea0b7b8ec411cfbc603e72aa594b
-SIZE (volatility-2.5.zip) = 3276052
+TIMESTAMP = 1483110602
+SHA256 (volatility-2.6.zip) = 5b73050d72bf94870ffce22843f03d4b0b7764011dec29ef1a0a5b1b46cf9295
+SIZE (volatility-2.6.zip) = 4179806
diff --git a/security/py-volatility/files/patch-setup.py b/security/py-volatility/files/patch-setup.py
deleted file mode 100644
index 5cc53afa6fec..000000000000
--- a/security/py-volatility/files/patch-setup.py
+++ /dev/null
@@ -1,14 +0,0 @@
---- setup.py.orig 2015-10-21 20:39:22 UTC
-+++ setup.py
-@@ -44,7 +44,10 @@ def find_files(topdirs, py = False):
- ret = []
- for topdir in topdirs:
- for r, _ds, fs in os.walk(topdir):
-- ret.append((r, [ os.path.join(r, f) for f in fs if (f.endswith('.py') or not py)]))
-+ fl = [ os.path.join(r, f) for f in fs if (f.endswith('.py') or not py)]
-+ # Do not record directories (with no regular files inside)
-+ if len(fl) > 0:
-+ ret.append((r, fl))
- return ret
-
- opts = {}
diff --git a/security/py-volatility/files/patch-volatility_plugins_malware_psxview.py b/security/py-volatility/files/patch-volatility_plugins_malware_psxview.py
index 3381ddc4777f..d4daec9cd89e 100644
--- a/security/py-volatility/files/patch-volatility_plugins_malware_psxview.py
+++ b/security/py-volatility/files/patch-volatility_plugins_malware_psxview.py
@@ -1,4 +1,4 @@
---- volatility/plugins/malware/psxview.py.orig 2015-10-21 20:39:22 UTC
+--- volatility/plugins/malware/psxview.py.orig 2016-12-27 15:54:47 UTC
+++ volatility/plugins/malware/psxview.py
@@ -35,8 +35,8 @@ import volatility.plugins.addrspaces.sta
try:
diff --git a/security/py-volatility/files/patch-volatility_renderers_xlsx.py b/security/py-volatility/files/patch-volatility_renderers_xlsx.py
index 4e3df6a9a9e9..f9953e909011 100644
--- a/security/py-volatility/files/patch-volatility_renderers_xlsx.py
+++ b/security/py-volatility/files/patch-volatility_renderers_xlsx.py
@@ -1,4 +1,4 @@
---- volatility/renderers/xlsx.py.orig 2015-10-21 20:39:22 UTC
+--- volatility/renderers/xlsx.py.orig 2016-12-27 15:54:47 UTC
+++ volatility/renderers/xlsx.py
@@ -6,8 +6,8 @@ __author__ = "gleeda"
try: