aboutsummaryrefslogtreecommitdiff
path: root/security/py-xmlsec/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:04:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:04:26 +0000
commit22d139791080099a807144012808e59c60621fa7 (patch)
treed608f6fd21ea509bd4a06c59b9c46124d4666d02 /security/py-xmlsec/Makefile
parent815f710e2a64989747b3b108ea6cc5b788e47e4f (diff)
downloadports-22d139791080099a807144012808e59c60621fa7.tar.gz
ports-22d139791080099a807144012808e59c60621fa7.zip
Notes
Diffstat (limited to 'security/py-xmlsec/Makefile')
-rw-r--r--security/py-xmlsec/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/security/py-xmlsec/Makefile b/security/py-xmlsec/Makefile
new file mode 100644
index 000000000000..815979e13dcf
--- /dev/null
+++ b/security/py-xmlsec/Makefile
@@ -0,0 +1,47 @@
+# ex:ts=8
+# Ports collection makefile for: pyxmlsec
+# Date created: Feb 3, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlsec
+PORTVERSION= 0.2.0
+CATEGORIES= security python
+MASTER_SITES= http://pyxmlsec.labs.libre-entreprise.org/releases/sources/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A set of Python bindings for XML Security Library
+
+LIB_DEPENDS= xmlsec1.3:${PORTSDIR}/security/xmlsec1
+
+USE_REINPLACE= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+post-install:
+ @${FIND} ${PYTHON_SITELIBDIR} -name "xmlsec*" | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/html/* ${DOCSDIR}
+ @${FIND} ${DOCSDIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>