aboutsummaryrefslogtreecommitdiff
path: root/security/py-xmlsec
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-19 17:38:46 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-19 17:38:46 +0000
commitd5f9e8dd85148f69ddb5c658bf43b32fae4fb8f5 (patch)
treedcf1a00c6f64559e4117f1950e62208a9ebae71b /security/py-xmlsec
parent20fb07058b9fc5e8fb288dffe85c35655f83534d (diff)
downloadports-d5f9e8dd85148f69ddb5c658bf43b32fae4fb8f5.tar.gz
ports-d5f9e8dd85148f69ddb5c658bf43b32fae4fb8f5.zip
Notes
Diffstat (limited to 'security/py-xmlsec')
-rw-r--r--security/py-xmlsec/Makefile11
-rw-r--r--security/py-xmlsec/pkg-plist90
2 files changed, 91 insertions, 10 deletions
diff --git a/security/py-xmlsec/Makefile b/security/py-xmlsec/Makefile
index 20ae50ee28e7..28e3114b60ac 100644
--- a/security/py-xmlsec/Makefile
+++ b/security/py-xmlsec/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A set of Python bindings for XML Security Library
LIB_DEPENDS= xmlsec1.3:${PORTSDIR}/security/xmlsec1
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
USE_PYTHON= 2.2+
USE_PYDISTUTILS= yes
@@ -25,22 +26,12 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-install:
- @${FIND} ${PYTHONPREFIX_SITELIBDIR} -name "xmlsec*" | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/docs/html/* ${DOCSDIR}
- @${FIND} ${DOCSDIR} -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
- @${FIND} ${EXAMPLESDIR} -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>
diff --git a/security/py-xmlsec/pkg-plist b/security/py-xmlsec/pkg-plist
new file mode 100644
index 000000000000..f0b9861ba559
--- /dev/null
+++ b/security/py-xmlsec/pkg-plist
@@ -0,0 +1,90 @@
+%%PYTHON_SITELIBDIR%%/xmlsec.py
+%%PYTHON_SITELIBDIR%%/xmlsec_strings.py
+%%PYTHON_SITELIBDIR%%/xmlsecmod.so
+%%PYTHON_SITELIBDIR%%/xmlsec.pyc
+%%PYTHON_SITELIBDIR%%/xmlsec_strings.pyc
+%%PYTHON_SITELIBDIR%%/xmlsec.pyo
+%%PYTHON_SITELIBDIR%%/xmlsec_strings.pyo
+%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TransformId-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TransformCtx-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.Transform-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplTransform-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplSignature-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplRetrievalMethod-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplReference-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplObject-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplManifest-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplKeyInfo-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplEncData-class.html
+%%PORTDOCS%%%%DOCSDIR%%/trees.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.TmplCipherReference-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.PtrListId-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.PtrList-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.NodeSet-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeysMngr-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeyStoreId-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeyStore-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeyReq-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeyInfoCtx-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeyDataId-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.KeyData-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.Key-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.Error-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec-module.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.EncCtx-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.DSigReferenceCtx-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.DSigCtx-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.Buffer-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec.Base64Ctx-class.html
+%%PORTDOCS%%%%DOCSDIR%%/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-xmlsec_strings-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-xmlsec-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-everything.html
+%%PORTDOCS%%%%DOCSDIR%%/libxml2.xmlNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/libxml2.xmlCore-class.html
+%%PORTDOCS%%%%DOCSDIR%%/indices.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help.html
+%%PORTDOCS%%%%DOCSDIR%%/frames.html
+%%PORTDOCS%%%%DOCSDIR%%/exceptions.Exception-class.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec_strings-module.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/decrypt1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify4-tmpl.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify4-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify4-bad-tmpl.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify4-bad-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify3.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify2.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign3.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign3-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign3-doc.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign2.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign2-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign2-doc.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign1-tmpl.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sign1-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/rsapub.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/rsakey.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/rsacert.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/rootcert.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/pyxmlsec-demo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt3.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt3-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt3-doc.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt2.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt2-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt2-doc.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt1-tmpl.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/encrypt1-res.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/deskey.bin
+%%PORTDOCS%%%%EXAMPLESDIR%%/decrypt3.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/decrypt2.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/decrypt2-res2.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/decrypt2-res1.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/verify4.py
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%