aboutsummaryrefslogtreecommitdiff
path: root/security/py-yara
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-05-23 16:05:41 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-05-23 16:05:41 +0000
commite9013eabd8f4839de359ab40f79802d1064f774a (patch)
tree29b01f63d03516833f34826936a58148e64b222a /security/py-yara
parent76403566a643703abffaf9374899f3122ca2415e (diff)
downloadports-e9013eabd8f4839de359ab40f79802d1064f774a.tar.gz
ports-e9013eabd8f4839de359ab40f79802d1064f774a.zip
Notes
Diffstat (limited to 'security/py-yara')
-rw-r--r--security/py-yara/Makefile7
-rw-r--r--security/py-yara/distinfo4
-rw-r--r--security/py-yara/files/patch-setup.py14
3 files changed, 15 insertions, 10 deletions
diff --git a/security/py-yara/Makefile b/security/py-yara/Makefile
index a4006227533d..efaad8289f56 100644
--- a/security/py-yara/Makefile
+++ b/security/py-yara/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= yara
-PORTVERSION= 1.4a
+PORTVERSION= 1.5
CATEGORIES= security
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,8 +21,11 @@ PROJECTHOST= yara-project
MAKE_JOBS_SAFE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-PYDISTUTILS_EGGINFO= yara_python-1.4a-py2.7.egg-info
+PYDISTUTILS_EGGINFO= yara_python-1.5-${PYTHON_VERSION:S/thon//}.egg-info
PLIST_FILES= %%PYTHON_SITELIBDIR%%/yara.so
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/security/py-yara/distinfo b/security/py-yara/distinfo
index 78da7a1b03ae..c832616d50f8 100644
--- a/security/py-yara/distinfo
+++ b/security/py-yara/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yara-python-1.4a.tar.gz) = 0221b6b5178edc99584fb0e082ebbc454e3e33701112f7041349e547a8aabc66
-SIZE (yara-python-1.4a.tar.gz) = 7504
+SHA256 (yara-python-1.5.tar.gz) = 77175498845e49e680022da4812967d041a5937c3daae54285d589e1b856f55a
+SIZE (yara-python-1.5.tar.gz) = 8072
diff --git a/security/py-yara/files/patch-setup.py b/security/py-yara/files/patch-setup.py
index 2a9ed18afcc8..551d7dabe562 100644
--- a/security/py-yara/files/patch-setup.py
+++ b/security/py-yara/files/patch-setup.py
@@ -1,12 +1,14 @@
---- ./setup.py.orig 2011-03-07 12:21:10.504810488 -0500
-+++ ./setup.py 2011-03-07 12:21:30.973804718 -0500
-@@ -11,8 +11,9 @@
+--- ./setup.py.orig 2011-03-08 15:18:51.000000000 -0500
++++ ./setup.py 2011-05-22 21:27:25.075485034 -0400
+@@ -10,9 +10,10 @@
+ ext_modules = [ Extension(
name='yara',
sources=['yara-python.c'],
- libraries=['yara','pcre'],
+- libraries=['yara','pcre'],
- include_dirs=['/usr/local/include']
-+ include_dirs=['/usr/local/include'],
-+ library_dirs=['/usr/local/lib']
++ libraries=['yara','re2'],
++ include_dirs=['%%LOCALBASE%%/include'],
++ library_dirs=['%%LOCALBASE%%/lib']
)])