aboutsummaryrefslogtreecommitdiff
path: root/security/py-zope.app.security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /security/py-zope.app.security
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'security/py-zope.app.security')
-rw-r--r--security/py-zope.app.security/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/security/py-zope.app.security/Makefile b/security/py-zope.app.security/Makefile
index fefaf856e045..59e63c7cc880 100644
--- a/security/py-zope.app.security/Makefile
+++ b/security/py-zope.app.security/Makefile
@@ -13,20 +13,20 @@ COMMENT= ZMI Views For Zope3 Security Components
LICENSE= ZPL21
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.app.localpermission>=0:security/py-zope.app.localpermission \
- ${PYTHON_PKGNAMEPREFIX}zope.app.pagetemplate>=0:devel/py-zope.app.pagetemplate \
- ${PYTHON_PKGNAMEPREFIX}zope.app.publisher>=0:devel/py-zope.app.publisher \
- ${PYTHON_PKGNAMEPREFIX}zope.authentication>=0:security/py-zope.authentication \
- ${PYTHON_PKGNAMEPREFIX}zope.i18n>=0:devel/py-zope.i18n \
- ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:textproc/py-zope.i18nmessageid \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface \
- ${PYTHON_PKGNAMEPREFIX}zope.principalregistry>=0:security/py-zope.principalregistry \
- ${PYTHON_PKGNAMEPREFIX}zope.publisher>=3.12:devel/py-zope.publisher \
- ${PYTHON_PKGNAMEPREFIX}zope.security>=0:security/py-zope.security \
- ${PYTHON_PKGNAMEPREFIX}zope.securitypolicy>=0:security/py-zope.securitypolicy \
- ${PYTHON_PKGNAMEPREFIX}zope.login>=0:security/py-zope.login
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.app.localpermission>=0:security/py-zope.app.localpermission@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.app.pagetemplate>=0:devel/py-zope.app.pagetemplate@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.app.publisher>=0:devel/py-zope.app.publisher@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.authentication>=0:security/py-zope.authentication@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18n>=0:devel/py-zope.i18n@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:textproc/py-zope.i18nmessageid@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.principalregistry>=0:security/py-zope.principalregistry@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>=3.12:devel/py-zope.publisher@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.security>=0:security/py-zope.security@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.securitypolicy>=0:security/py-zope.securitypolicy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.login>=0:security/py-zope.login@${FLAVOR}
-USES= python
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>