aboutsummaryrefslogtreecommitdiff
path: root/security/py-zope.securitypolicy/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-18 19:27:58 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-18 19:27:58 +0000
commit9ebd3bc0cd246355a5b43c3a89b41c64d81a3466 (patch)
tree25e5c244fcc1b7fe409da6386efdcfb35ff5759a /security/py-zope.securitypolicy/Makefile
parente4fd6df643dfd1b60615a5db67aa4006746ddc52 (diff)
Notes
Diffstat (limited to 'security/py-zope.securitypolicy/Makefile')
-rw-r--r--security/py-zope.securitypolicy/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/py-zope.securitypolicy/Makefile b/security/py-zope.securitypolicy/Makefile
new file mode 100644
index 000000000000..ebbb6126302d
--- /dev/null
+++ b/security/py-zope.securitypolicy/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: py-zope.securitypolicy
+# Date created: 18 December 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zope.securitypolicy
+PORTVERSION= 3.7.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Default security policy for Zope3
+
+LICENSE= ZPL21
+
+RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
+ ${PYTHON_PKGNAMEPREFIX}zope.annotation>=0:${PORTSDIR}/devel/py-zope.annotation \
+ ${PYTHON_PKGNAMEPREFIX}zope.authentication>=0:${PORTSDIR}/security/py-zope.authentication \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.configuration>=0:${PORTSDIR}/devel/py-zope.configuration \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.location>=0:${PORTSDIR}/devel/py-zope.location \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security \
+ ${PYTHON_PKGNAMEPREFIX}zope.dublincore>=3.7:${PORTSDIR}/devel/py-zope.dublincore
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>