aboutsummaryrefslogtreecommitdiff
path: root/security/qca-ossl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-02 18:55:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-02 18:55:39 +0000
commit45ba55420e28f442bfa3070b76a39aa6376199cd (patch)
treed8321828e63bf4a6e4641cf2ca1a9e37787822d5 /security/qca-ossl
parent3cf77ee6e996a1659645ab27edaa7a59d38b6774 (diff)
downloadports-45ba55420e28f442bfa3070b76a39aa6376199cd.tar.gz
ports-45ba55420e28f442bfa3070b76a39aa6376199cd.zip
Notes
Diffstat (limited to 'security/qca-ossl')
-rw-r--r--security/qca-ossl/Makefile7
-rw-r--r--security/qca-ossl/files/patch-qca-oss.cpp27
2 files changed, 32 insertions, 2 deletions
diff --git a/security/qca-ossl/Makefile b/security/qca-ossl/Makefile
index 8b6e353329ab..89c6c7fd88ce 100644
--- a/security/qca-ossl/Makefile
+++ b/security/qca-ossl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= qca-ossl
DISTVERSION= 2.0.0-beta3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://delta.affinix.com/download/qca/2.0/plugins/
@@ -26,10 +27,12 @@ CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LDFLAGS=${PTHREAD_LIBS}
CONFIGURE_ARGS= --plugins-path=${PREFIX}/${QT_PLUGINDIR} --qtdir=${LOCALBASE} \
- --with-qca=${LOCALBASE}
+ --with-qca=${LOCALBASE} \
+ --with-openssl-inc=${OPENSSLINC} \
+ --with-openssl-lib=${OPENSSLLIB}
QT_PLUGINDIR= lib/qt4/plugins
-
+++ qca-ossl.cpp 2009-02-26 06:41:17.000000000 +0100
PLIST_SUB+= QT_PLUGINDIR="${QT_PLUGINDIR}"
.include <bsd.port.mk>
diff --git a/security/qca-ossl/files/patch-qca-oss.cpp b/security/qca-ossl/files/patch-qca-oss.cpp
new file mode 100644
index 000000000000..75138984d073
--- /dev/null
+++ b/security/qca-ossl/files/patch-qca-oss.cpp
@@ -0,0 +1,27 @@
+--- qca-ossl.cpp.orig 2007-12-11 07:34:57.000000000 +0100
++++ qca-ossl.cpp 2009-02-26 06:41:17.000000000 +0100
+@@ -6597,9 +6597,11 @@
+ #ifdef SHA512_DIGEST_LENGTH
+ list += "sha512";
+ #endif
++#if 0
+ #ifdef OBJ_whirlpool
+ list += "whirlpool";
+ #endif
++#endif
+ return list;
+ }
+
+@@ -6810,10 +6812,12 @@
+ else if ( type == "sha512" )
+ return new opensslHashContext( EVP_sha512(), this, type);
+ #endif
++#if 0
+ #ifdef OBJ_whirlpool
+ else if ( type == "whirlpool" )
+ return new opensslHashContext( EVP_whirlpool(), this, type);
+ #endif
++#endif
+ else if ( type == "pbkdf1(sha1)" )
+ return new opensslPbkdf1Context( EVP_sha1(), this, type );
+ else if ( type == "pbkdf1(md2)" )