aboutsummaryrefslogtreecommitdiff
path: root/security/qca-tls
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-11-18 09:08:41 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-11-18 09:08:41 +0000
commite1663fc8751356ea85adbc3d09fe87d99629531f (patch)
tree3cc962c541489b5299415a20cbeac8cf73623ccd /security/qca-tls
parentf68497b9bf195c714a623fd7a80979dff99580a0 (diff)
downloadports-e1663fc8751356ea85adbc3d09fe87d99629531f.tar.gz
ports-e1663fc8751356ea85adbc3d09fe87d99629531f.zip
Notes
Diffstat (limited to 'security/qca-tls')
-rw-r--r--security/qca-tls/Makefile1
-rw-r--r--security/qca-tls/files/patch-configure39
2 files changed, 37 insertions, 3 deletions
diff --git a/security/qca-tls/Makefile b/security/qca-tls/Makefile
index 25b47ed13bbd..1f10f087010d 100644
--- a/security/qca-tls/Makefile
+++ b/security/qca-tls/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
diff --git a/security/qca-tls/files/patch-configure b/security/qca-tls/files/patch-configure
index 36ac56a8fda7..f7bc54689dcc 100644
--- a/security/qca-tls/files/patch-configure
+++ b/security/qca-tls/files/patch-configure
@@ -1,5 +1,26 @@
---- configure.orig Thu Dec 18 01:54:50 2003
-+++ configure Tue Jan 27 14:58:26 2004
+--- configure.orig Wed Dec 17 23:54:50 2003
++++ configure Tue Nov 16 12:33:52 2004
+@@ -20,17 +20,17 @@
+ while [ $# -gt 0 ]; do
+ case "$1" in
+ --qtdir=*)
+- QTDIR=`expr "${1}" : "--qtdir=\(.*\)"`
++ QTDIR="${1#--qtdir=}"
+ shift
+ ;;
+
+ --with-openssl-inc=*)
+- QC_WITH_OPENSSL_INC=`expr "${1}" : "--with-openssl-inc=\(.*\)"`
++ QC_WITH_OPENSSL_INC="${1#--with-openssl-inc=}"
+ shift
+ ;;
+
+ --with-openssl-lib=*)
+- QC_WITH_OPENSSL_LIB=`expr "${1}" : "--with-openssl-lib=\(.*\)"`
++ QC_WITH_OPENSSL_LIB="${1#--with-openssl-lib=}"
+ shift
+ ;;
+
@@ -43,6 +43,8 @@
esac
done
@@ -27,3 +48,17 @@
lib = s;
}
else {
+@@ -570,13 +570,6 @@
+ echo
+ exit 1;
+ fi
+-cat >Makefile.tmp <<EOT
+-export QTDIR = $QTDIR
+-EOT
+-cat Makefile >> Makefile.tmp
+-rm -f Makefile
+-cp -f Makefile.tmp Makefile
+-rm -f Makefile.tmp
+
+ echo
+ echo Good, your configure finished. Now run \'make\'.