aboutsummaryrefslogtreecommitdiff
path: root/security/qtfw/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-09-15 04:47:29 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-09-15 04:47:29 +0000
commit11a1c92c301c1042c558eec9265dfc3505d80cf1 (patch)
treea37c7fe6031872edc29960efa1b09ef5686f2743 /security/qtfw/Makefile
parentb8b3847d2812910550723a264ec53efcb154aac6 (diff)
downloadports-11a1c92c301c1042c558eec9265dfc3505d80cf1.tar.gz
ports-11a1c92c301c1042c558eec9265dfc3505d80cf1.zip
Notes
Diffstat (limited to 'security/qtfw/Makefile')
-rw-r--r--security/qtfw/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/security/qtfw/Makefile b/security/qtfw/Makefile
index c457a2d19610..2136fd271969 100644
--- a/security/qtfw/Makefile
+++ b/security/qtfw/Makefile
@@ -6,18 +6,34 @@
#
PORTNAME= qtfw
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@databits.net
-ALL_TARGET= ${PORTNAME}
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
USE_QT_VER= 2
+CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS}"
-post-install:
+pre-patch:
+ @${PERL} -pi.orig -e 's|^\ *CXXFLAGS=.*||' \
+ ${WRKSRC}/configure
+ @${PERL} -pi.orig -e 's|\-O2||' ${WRKSRC}/qtfw/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/qtfw/qtfw ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+.for files in gear qtfwlogo
+ @${INSTALL_DATA} ${WRKSRC}/pics/${files}.png ${DATADIR}
+.endfor
.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in index.html ipfwman.html qtfwlogo.jpeg
+ @${INSTALL_DATA} ${WRKSRC}/docs/${docs} ${DOCSDIR}
+.endfor
@${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
@${INSTALL_DATA} ${WRKSRC}/examples/* \
${PREFIX}/share/examples/${PORTNAME}