aboutsummaryrefslogtreecommitdiff
path: root/security/qtfw
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-29 11:29:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-29 11:29:30 +0000
commit0f4eb80eba136045b7be0e25ef6ad1f64dd38599 (patch)
treec8ebad3b668123e2cb3d10ada9f55351f35be573 /security/qtfw
parent7c2e77dac94916f5472de6368d52c759e4695525 (diff)
downloadports-0f4eb80eba136045b7be0e25ef6ad1f64dd38599.tar.gz
ports-0f4eb80eba136045b7be0e25ef6ad1f64dd38599.zip
Notes
Diffstat (limited to 'security/qtfw')
-rw-r--r--security/qtfw/Makefile26
-rw-r--r--security/qtfw/distinfo1
-rw-r--r--security/qtfw/files/patch-Makefile39
-rw-r--r--security/qtfw/pkg-comment1
-rw-r--r--security/qtfw/pkg-descr5
-rw-r--r--security/qtfw/pkg-plist4
6 files changed, 76 insertions, 0 deletions
diff --git a/security/qtfw/Makefile b/security/qtfw/Makefile
new file mode 100644
index 000000000000..c457a2d19610
--- /dev/null
+++ b/security/qtfw/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: qtfw
+# Date created: Sat Aug 25 10:42:02 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtfw
+PORTVERSION= 0.3.1
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pat@databits.net
+
+ALL_TARGET= ${PORTNAME}
+USE_QT_VER= 2
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/examples/* \
+ ${PREFIX}/share/examples/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/qtfw/distinfo b/security/qtfw/distinfo
new file mode 100644
index 000000000000..efba740b1df9
--- /dev/null
+++ b/security/qtfw/distinfo
@@ -0,0 +1 @@
+MD5 (qtfw-0.3.1.tar.gz) = 6860180726c24deea67218a34d83c7a8
diff --git a/security/qtfw/files/patch-Makefile b/security/qtfw/files/patch-Makefile
new file mode 100644
index 000000000000..e230c41c01e5
--- /dev/null
+++ b/security/qtfw/files/patch-Makefile
@@ -0,0 +1,39 @@
+--- Makefile.orig Fri Aug 24 12:17:26 2001
++++ Makefile Sat Aug 25 10:49:38 2001
+@@ -7,18 +7,18 @@
+ aboutdlg.cpp moc_aboutdlg.cpp
+ OBJS=$(SOURCES:.cpp=.o)
+
+-CFLAGS=-g -Wall -I/usr/X11R6/include/qt2
+-LDFLAGS=-L/usr/X11R6/lib -lqt2
++CFLAGS=-g -Wall -I${X11BASE}/include/qt2
++LDFLAGS=-L${X11BASE}/lib -lqt2
+
+-INSTALL_PREFIX=/usr/X11R6
++INSTALL_PREFIX=${PREFIX}
+ HTMLS:=`echo docs/*.html`
+ EXAMPLES:=`echo examples/*.html`
+
+ $(TARGET):$(OBJS)
+- g++ $(LDFLAGS) -o $(TARGET) $(OBJS)
++ ${CXX} $(LDFLAGS) -o $(TARGET) $(OBJS)
+
+ .cpp.o:
+- g++ $(CFLAGS) -c $<
++ ${CXX} $(CFLAGS) -c $<
+
+ moc_mainformbase.cpp : mainformbase.H
+ moc2 mainformbase.H > moc_mainformbase.cpp
+@@ -57,11 +57,7 @@
+ rm -f moc_*
+
+ install: $(TARGET)
+- install -c $(TARGET) $(INSTALL_PREFIX)/bin/
+- install -d $(INSTALL_PREFIX)/share/$(TARGET)/docs/
+- install -d $(INSTALL_PREFIX)/share/$(TARGET)/examples/
+- cp -R docs/ $(INSTALL_PREFIX)/share/$(TARGET)/docs/
+- cp -R examples/ $(INSTALL_PREFIX)/share/$(TARGET)/examples/
++ ${BSD_INSTALL_PROGRAM} $(TARGET) $(INSTALL_PREFIX)/bin
+
+ uninstall:
+ rm -f $(INSTALL_PREFIX)/bin/$(TARGET)
diff --git a/security/qtfw/pkg-comment b/security/qtfw/pkg-comment
new file mode 100644
index 000000000000..9f7d9b2f6466
--- /dev/null
+++ b/security/qtfw/pkg-comment
@@ -0,0 +1 @@
+A GUI frontend for ipfw utility in FreeBSD
diff --git a/security/qtfw/pkg-descr b/security/qtfw/pkg-descr
new file mode 100644
index 000000000000..46460368d799
--- /dev/null
+++ b/security/qtfw/pkg-descr
@@ -0,0 +1,5 @@
+Qtfw is a Qt gui frontend for ipfw utility in FreeBSD. It helps
+configuring firewall in FreeBSD with a nice and comprehensive user
+interface.
+
+WWW: http://sourceforge.net/projects/qtfw/
diff --git a/security/qtfw/pkg-plist b/security/qtfw/pkg-plist
new file mode 100644
index 000000000000..4860689731ff
--- /dev/null
+++ b/security/qtfw/pkg-plist
@@ -0,0 +1,4 @@
+bin/qtfw
+%%PORTDOCS%%share/examples/qtfw/base.rules
+%%PORTDOCS%%share/examples/qtfw/client.rules
+%%PORTDOCS%%@dirrm share/examples/qtfw