aboutsummaryrefslogtreecommitdiff
path: root/security/qtfw
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-09-15 04:47:29 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-09-15 04:47:29 +0000
commit11a1c92c301c1042c558eec9265dfc3505d80cf1 (patch)
treea37c7fe6031872edc29960efa1b09ef5686f2743 /security/qtfw
parentb8b3847d2812910550723a264ec53efcb154aac6 (diff)
downloadports-11a1c92c301c1042c558eec9265dfc3505d80cf1.tar.gz
ports-11a1c92c301c1042c558eec9265dfc3505d80cf1.zip
Notes
Diffstat (limited to 'security/qtfw')
-rw-r--r--security/qtfw/Makefile22
-rw-r--r--security/qtfw/distinfo2
-rw-r--r--security/qtfw/files/patch-Makefile39
-rw-r--r--security/qtfw/pkg-plist7
4 files changed, 27 insertions, 43 deletions
diff --git a/security/qtfw/Makefile b/security/qtfw/Makefile
index c457a2d19610..2136fd271969 100644
--- a/security/qtfw/Makefile
+++ b/security/qtfw/Makefile
@@ -6,18 +6,34 @@
#
PORTNAME= qtfw
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@databits.net
-ALL_TARGET= ${PORTNAME}
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
USE_QT_VER= 2
+CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS}"
-post-install:
+pre-patch:
+ @${PERL} -pi.orig -e 's|^\ *CXXFLAGS=.*||' \
+ ${WRKSRC}/configure
+ @${PERL} -pi.orig -e 's|\-O2||' ${WRKSRC}/qtfw/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/qtfw/qtfw ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+.for files in gear qtfwlogo
+ @${INSTALL_DATA} ${WRKSRC}/pics/${files}.png ${DATADIR}
+.endfor
.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in index.html ipfwman.html qtfwlogo.jpeg
+ @${INSTALL_DATA} ${WRKSRC}/docs/${docs} ${DOCSDIR}
+.endfor
@${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
@${INSTALL_DATA} ${WRKSRC}/examples/* \
${PREFIX}/share/examples/${PORTNAME}
diff --git a/security/qtfw/distinfo b/security/qtfw/distinfo
index efba740b1df9..a06f18095f5c 100644
--- a/security/qtfw/distinfo
+++ b/security/qtfw/distinfo
@@ -1 +1 @@
-MD5 (qtfw-0.3.1.tar.gz) = 6860180726c24deea67218a34d83c7a8
+MD5 (qtfw-0.4.tar.gz) = f366a3f9bbc05fc6f103465228d70566
diff --git a/security/qtfw/files/patch-Makefile b/security/qtfw/files/patch-Makefile
deleted file mode 100644
index e230c41c01e5..000000000000
--- a/security/qtfw/files/patch-Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
---- Makefile.orig Fri Aug 24 12:17:26 2001
-+++ Makefile Sat Aug 25 10:49:38 2001
-@@ -7,18 +7,18 @@
- aboutdlg.cpp moc_aboutdlg.cpp
- OBJS=$(SOURCES:.cpp=.o)
-
--CFLAGS=-g -Wall -I/usr/X11R6/include/qt2
--LDFLAGS=-L/usr/X11R6/lib -lqt2
-+CFLAGS=-g -Wall -I${X11BASE}/include/qt2
-+LDFLAGS=-L${X11BASE}/lib -lqt2
-
--INSTALL_PREFIX=/usr/X11R6
-+INSTALL_PREFIX=${PREFIX}
- HTMLS:=`echo docs/*.html`
- EXAMPLES:=`echo examples/*.html`
-
- $(TARGET):$(OBJS)
-- g++ $(LDFLAGS) -o $(TARGET) $(OBJS)
-+ ${CXX} $(LDFLAGS) -o $(TARGET) $(OBJS)
-
- .cpp.o:
-- g++ $(CFLAGS) -c $<
-+ ${CXX} $(CFLAGS) -c $<
-
- moc_mainformbase.cpp : mainformbase.H
- moc2 mainformbase.H > moc_mainformbase.cpp
-@@ -57,11 +57,7 @@
- rm -f moc_*
-
- install: $(TARGET)
-- install -c $(TARGET) $(INSTALL_PREFIX)/bin/
-- install -d $(INSTALL_PREFIX)/share/$(TARGET)/docs/
-- install -d $(INSTALL_PREFIX)/share/$(TARGET)/examples/
-- cp -R docs/ $(INSTALL_PREFIX)/share/$(TARGET)/docs/
-- cp -R examples/ $(INSTALL_PREFIX)/share/$(TARGET)/examples/
-+ ${BSD_INSTALL_PROGRAM} $(TARGET) $(INSTALL_PREFIX)/bin
-
- uninstall:
- rm -f $(INSTALL_PREFIX)/bin/$(TARGET)
diff --git a/security/qtfw/pkg-plist b/security/qtfw/pkg-plist
index 4860689731ff..8455b61f91d9 100644
--- a/security/qtfw/pkg-plist
+++ b/security/qtfw/pkg-plist
@@ -1,4 +1,11 @@
bin/qtfw
+%%PORTDOCS%%share/doc/qtfw/index.html
+%%PORTDOCS%%share/doc/qtfw/ipfwman.html
+%%PORTDOCS%%share/doc/qtfw/qtfwlogo.jpeg
%%PORTDOCS%%share/examples/qtfw/base.rules
%%PORTDOCS%%share/examples/qtfw/client.rules
+share/qtfw/gear.png
+share/qtfw/qtfwlogo.png
+@dirrm share/qtfw
%%PORTDOCS%%@dirrm share/examples/qtfw
+%%PORTDOCS%%@dirrm share/doc/qtfw