aboutsummaryrefslogtreecommitdiff
path: root/security/quantis
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-06-12 06:54:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-06-12 06:54:13 +0000
commitc747ed147a33552966591a4227d7f34e0e41aef3 (patch)
tree717556bd187d3e520fbda0017a80f5360fc63297 /security/quantis
parenta6a89abfbefa697a43128c06b595464f99052fda (diff)
Notes
Diffstat (limited to 'security/quantis')
-rw-r--r--security/quantis/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index 7e6002b59459..68a5548de105 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ale
MAINTAINER= ale@FreeBSD.org
COMMENT= Libraries and utilities to access Quantis devices
-OPTIONS= PCI "Enable Quantis PCI support (FreeBSD >= 7.0)" on \
+OPTIONS= PCI "Enable Quantis PCI support" on \
USB "Enable Quantis USB support (FreeBSD >= 8.1)" on \
JAVA "Enable Java support" on \
COMPAT "Build API v1 compatibility libraries" off \
@@ -45,7 +45,11 @@ CMAKE_BUILD_TYPE=Debug
.include <bsd.port.pre.mk>
-.if defined(WITH_PCI) && ${OSVERSION} >= 700000
+.if ${OSVERSION} < 700000
+IGNORE= requires FreeBSD >= 7
+.endif
+
+.if defined(WITH_PCI)
RUN_DEPENDS+= ${KMODDIR}/quantis.ko:${PORTSDIR}/security/quantis-kmod
.else
CMAKE_ARGS+= -DDISABLE_QUANTIS_PCI=1