aboutsummaryrefslogtreecommitdiff
path: root/security/quantis
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-09-24 14:22:28 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-09-24 14:22:28 +0000
commit31f4e18f6dce27a152b3548e3630d2d4119f0568 (patch)
tree5fd3928737b2d4afc20b1f9db8c413d040740473 /security/quantis
parente9b9700f2cf162165ae3e235e44143ba95491ceb (diff)
downloadports-31f4e18f6dce27a152b3548e3630d2d4119f0568.tar.gz
ports-31f4e18f6dce27a152b3548e3630d2d4119f0568.zip
Notes
Diffstat (limited to 'security/quantis')
-rw-r--r--security/quantis/Makefile47
-rw-r--r--security/quantis/distinfo4
-rw-r--r--security/quantis/files/patch-QuantisExtensions_CMakeLists.txt10
-rw-r--r--security/quantis/files/patch-QuantisExtensions_QuantisExtractor_C.c15
-rw-r--r--security/quantis/pkg-plist15
5 files changed, 61 insertions, 30 deletions
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index ee3635d4b17d..77f896e2f090 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: quantis
-# Date created: 10 May 2010
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= quantis
-DISTVERSION= v11.12.13
-PORTREVISION= 1
+DISTVERSION= v12.09.12
CATEGORIES= security devel java
MASTER_SITES= http://www.idquantique.com/files/products/quantis/ \
${MASTER_SITE_LOCAL}
@@ -17,17 +12,21 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= ale@FreeBSD.org
COMMENT= Libraries and utilities to access Quantis devices
-OPTIONS= PCI "Enable Quantis PCI support" on \
- USB "Enable Quantis USB support (FreeBSD >= 8.1)" on \
- JAVA "Enable Java support" on \
- COMPAT "Build API v1 compatibility libraries" off \
- TOOL "Build EasyQuantis application" on \
- GUI "Build QT4 GUI for EasyQuantis application" on
-
-LICENSE_COMB= dual
LICENSE= BSD GPLv2
+LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/Quantis-${DISTVERSION}/License.txt
+OPTIONS_DEFINE= PCI USB JAVA COMPAT TOOL GUI DOCS EXAMPLES
+OPTIONS_DEFAULT=PCI USB JAVA TOOL GUI
+NO_OPTIONS_SORT=yes
+
+PCI_DESC= Enable Quantis PCI support
+USB_DESC= Enable Quantis USB support (FreeBSD >= 8.1)
+JAVA_DESC= Enable Java support
+COMPAT_DESC= Build API v1 compatibility libraries
+TOOL_DESC= Build EasyQuantis application
+GUI_DESC= Build QT4 GUI for EasyQuantis application
+
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aqo
USE_CMAKE= yes
@@ -47,17 +46,17 @@ PORTEXAMPLES= *
IGNORE= requires FreeBSD >= 7
.endif
-.if defined(WITH_PCI)
+.if ${PORT_OPTIONS:MPCI}
RUN_DEPENDS+= ${KMODDIR}/quantis.ko:${PORTSDIR}/security/quantis-kmod
.else
CMAKE_ARGS+= -DDISABLE_QUANTIS_PCI=1
.endif
-.if defined(WITHOUT_USB) || ${OSVERSION} < 801000
+.if empty(PORT_OPTIONS:MUSB) || ${OSVERSION} < 801000
CMAKE_ARGS+= -DDISABLE_QUANTIS_USB=1
.endif
-.if defined(WITH_JAVA)
+.if ${PORT_OPTIONS:MJAVA}
USE_JAVA= yes
JAVA_VERSION= 1.5+
JAVA_OS= native
@@ -65,7 +64,7 @@ JAVA_OS= native
CMAKE_ARGS+= -DDISABLE_QUANTIS_JAVA=1
.endif
-.if defined(WITH_COMPAT)
+.if ${PORT_OPTIONS:MCOMPAT}
CMAKE_ARGS+= -DENABLE_QUANTIS_COMPAT=1
PLIST_SUB+= COMPAT=""
@@ -73,11 +72,11 @@ PLIST_SUB+= COMPAT=""
PLIST_SUB+= COMPAT="@comment "
.endif
-.if defined(WITH_TOOL)
+.if ${PORT_OPTIONS:MTOOL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libboost_date_time.a:${PORTSDIR}/devel/boost-libs
CXXFLAGS+= -I${LOCALBASE}/include
-. if defined(WITH_GUI)
+. if ${PORT_OPTIONS:MGUI}
USE_QT4+= gui moc_build uic_build rcc_build qmake_build
. else
CMAKE_ARGS+= -DDISABLE_EASYQUANTIS_GUI=1
@@ -95,15 +94,15 @@ post-patch:
${WRKSRC}/CMake/CompilersFlags.cmake
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/../*.txt ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/../User_Manual.pdf ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/../Samples; ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.if defined(WITH_USB) && ${OSVERSION} >= 801000
+.if ${PORT_OPTIONS:MUSB} && ${OSVERSION} >= 801000
@${MKDIR} ${EXAMPLESDIR}/devd
${INSTALL_DATA} ${FILESDIR}/quantis.conf ${EXAMPLESDIR}/devd
@${CAT} ${PKGMESSAGE}
diff --git a/security/quantis/distinfo b/security/quantis/distinfo
index 9af4c5c2f1df..8cdbc8d355bb 100644
--- a/security/quantis/distinfo
+++ b/security/quantis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quantis-v11.12.13-src.zip) = 1152885033434a0a768390d6dcd20c2d0d913b484f11553a6e3619e7def36277
-SIZE (quantis-v11.12.13-src.zip) = 1897920
+SHA256 (quantis-v12.09.12-src.zip) = 58201ccb36bef8d0e711a9a346a4343b68b6326672af9f3262da0b9350782b1e
+SIZE (quantis-v12.09.12-src.zip) = 4606543
diff --git a/security/quantis/files/patch-QuantisExtensions_CMakeLists.txt b/security/quantis/files/patch-QuantisExtensions_CMakeLists.txt
new file mode 100644
index 000000000000..c3dfbb978cfb
--- /dev/null
+++ b/security/quantis/files/patch-QuantisExtensions_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- QuantisExtensions/CMakeLists.txt.orig 2012-09-24 16:08:08.000000000 +0200
++++ QuantisExtensions/CMakeLists.txt 2012-09-24 16:08:24.000000000 +0200
+@@ -58,6 +58,6 @@
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIB_DIR}
+ )
+
+-INSTALL(FILES ${Public_Headers} DESTINATION include)
++INSTALL(FILES ${Public_Headers} DESTINATION include/QuantisExtensions)
+
+
diff --git a/security/quantis/files/patch-QuantisExtensions_QuantisExtractor_C.c b/security/quantis/files/patch-QuantisExtensions_QuantisExtractor_C.c
new file mode 100644
index 000000000000..038c22ee9af1
--- /dev/null
+++ b/security/quantis/files/patch-QuantisExtensions_QuantisExtractor_C.c
@@ -0,0 +1,15 @@
+--- QuantisExtensions/QuantisExtractor_C.c.orig 2012-09-24 15:42:36.000000000 +0200
++++ QuantisExtensions/QuantisExtractor_C.c 2012-09-24 15:42:56.000000000 +0200
+@@ -53,7 +53,11 @@
+ #include "../Quantis/Conversion.h"
+ #include <stdio.h>
+ #include <math.h>
+-#include <malloc.h>
++#ifdef HAVE_MALLOC_H
++# include <malloc.h>
++#else
++# include <stdlib.h>
++#endif
+
+
+ /* Size of the buffer used for QuantisReadXXX methods */
diff --git a/security/quantis/pkg-plist b/security/quantis/pkg-plist
index f39d875a92f3..26b255568d2d 100644
--- a/security/quantis/pkg-plist
+++ b/security/quantis/pkg-plist
@@ -10,20 +10,27 @@ include/Quantis/Quantis_Java.h
include/Quantis/Quantis_random_device.hpp
include/Quantis/msc_stdint.h
include/Quantis/resource.h
+include/QuantisExtensions/QuantisExtractor.h
+include/QuantisExtensions/QuantisExtractor.hpp
lib/libQuantis-NoHw.a
lib/libQuantis-NoHw.so
lib/libQuantis-NoHw.so.2
-lib/libQuantis-NoHw.so.2.9.0
+lib/libQuantis-NoHw.so.2.10.0
lib/libQuantis.a
lib/libQuantis.so
lib/libQuantis.so.2
-lib/libQuantis.so.2.9.0
+lib/libQuantis.so.2.10.0
+lib/libQuantis_Extensions.a
+lib/libQuantis_Extensions.so
+lib/libQuantis_Extensions.so.2
+lib/libQuantis_Extensions.so.2.10.0
%%COMPAT%%lib/libQuantisPci-Compat.a
%%COMPAT%%lib/libQuantisPci-Compat.so
%%COMPAT%%lib/libQuantisPci-Compat.so.2
-%%COMPAT%%lib/libQuantisPci-Compat.so.2.9.0
+%%COMPAT%%lib/libQuantisPci-Compat.so.2.10.0
%%COMPAT%%lib/libQuantisUsb-Compat.a
%%COMPAT%%lib/libQuantisUsb-Compat.so
%%COMPAT%%lib/libQuantisUsb-Compat.so.2
-%%COMPAT%%lib/libQuantisUsb-Compat.so.2.9.0
+%%COMPAT%%lib/libQuantisUsb-Compat.so.2.10.0
@dirrm include/Quantis
+@dirrm include/QuantisExtensions