aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2/Makefile
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-07-05 09:19:28 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-07-05 09:19:28 +0000
commitc693e8e9e0c4cffe2ddd5de2014fc2aba4eeb583 (patch)
tree66d7cf37f936c9750c2d4863a65fe792cd52faeb /security/racoon2/Makefile
parent51190c35ea3dcf9768527b0b76505c20b778a03a (diff)
downloadports-c693e8e9e0c4cffe2ddd5de2014fc2aba4eeb583.tar.gz
ports-c693e8e9e0c4cffe2ddd5de2014fc2aba4eeb583.zip
Notes
Diffstat (limited to 'security/racoon2/Makefile')
-rw-r--r--security/racoon2/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
new file mode 100644
index 000000000000..84a796e75126
--- /dev/null
+++ b/security/racoon2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: racoon
+# Date created: 4 July 2000
+# Whom: sumikawa
+#
+# $FreeBSD$
+#
+
+PORTNAME= racoon
+PORTVERSION= 20000705a
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
+
+MAINTAINER= sumikawa@FreeBSD.org
+
+.if !exists(/usr/lib/libipsec.so.1)
+BROKEN= "You must upgrade the OS"
+.endif
+
+USE_OPENSSL= RSA
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/racoon
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+=CPPFLAGS=-I${LOCALBASE}/include CFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS="-L${LOCALBASE}/lib -L${WRKSRC}/../libipsec"
+CONFIGURE_ARGS+=--enable-debug
+CONFIGURE_ARGS+=--enable-ipv6
+CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
+
+MAN5= racoon.conf.5
+MAN8= racoon.8
+
+pre-patch:
+ ${MV} ${WRKSRC}/racoon.8 ${WRKSRC}/racoon.8.in
+
+pre-configure:
+ (cd ${WRKSRC}/../libipsec; make)
+
+.include <bsd.port.mk>