aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-11-22 18:42:03 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-11-22 18:42:03 +0000
commitd128e6b816c47e350ba91153f9f4e5c34933f922 (patch)
tree228e4044b814c7b5d918eb2ef7881888605b86d5 /security/racoon2
parentd9da40e963e7759693b776eb15a231df3b16ecc4 (diff)
downloadports-d128e6b816c47e350ba91153f9f4e5c34933f922.tar.gz
ports-d128e6b816c47e350ba91153f9f4e5c34933f922.zip
Notes
Diffstat (limited to 'security/racoon2')
-rw-r--r--security/racoon2/Makefile1
-rw-r--r--security/racoon2/files/patch-crypto_openssl.c42
2 files changed, 43 insertions, 0 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 49bf69bee628..573cff96820d 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= racoon
PORTVERSION= 20040818a
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
diff --git a/security/racoon2/files/patch-crypto_openssl.c b/security/racoon2/files/patch-crypto_openssl.c
new file mode 100644
index 000000000000..3f243d19c8e2
--- /dev/null
+++ b/security/racoon2/files/patch-crypto_openssl.c
@@ -0,0 +1,42 @@
+--- crypto_openssl.old.c 2004-04-09 22:25:56.000000000 +0530
++++ crypto_openssl.c 2004-08-02 20:30:03.000000000 +0530
+@@ -1654,6 +1654,7 @@
+
+ HMAC_Final((HMAC_CTX *)c, res->v, &l);
+ res->l = l;
++ HMAC_cleanup((HMAC_CTX *)c);
+ (void)racoon_free(c);
+
+ if (SHA512_DIGEST_LENGTH != res->l) {
+@@ -1710,6 +1711,7 @@
+
+ HMAC_Final((HMAC_CTX *)c, res->v, &l);
+ res->l = l;
++ HMAC_cleanup((HMAC_CTX *)c);
+ (void)racoon_free(c);
+
+ if (SHA384_DIGEST_LENGTH != res->l) {
+@@ -1766,6 +1768,7 @@
+
+ HMAC_Final((HMAC_CTX *)c, res->v, &l);
+ res->l = l;
++ HMAC_cleanup((HMAC_CTX *)c);
+ (void)racoon_free(c);
+
+ if (SHA256_DIGEST_LENGTH != res->l) {
+@@ -1823,6 +1826,7 @@
+
+ HMAC_Final((HMAC_CTX *)c, res->v, &l);
+ res->l = l;
++ HMAC_cleanup((HMAC_CTX *)c);
+ (void)racoon_free(c);
+
+ if (SHA_DIGEST_LENGTH != res->l) {
+@@ -1879,6 +1883,7 @@
+
+ HMAC_Final((HMAC_CTX *)c, res->v, &l);
+ res->l = l;
++ HMAC_cleanup((HMAC_CTX *)c);
+ (void)racoon_free(c);
+
+ if (MD5_DIGEST_LENGTH != res->l) {