aboutsummaryrefslogtreecommitdiff
path: root/security/rain
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-30 14:56:29 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-30 14:56:29 +0000
commitc8d50ea6f1cb988d950d340d75fedb16aeece69a (patch)
treebb8c897ec5ef6d22f627f99b8e4f9c5bfcc7c642 /security/rain
parent0cce0978731a41aa4bf690db91d44a0fd4177879 (diff)
downloadports-c8d50ea6f1cb988d950d340d75fedb16aeece69a.tar.gz
ports-c8d50ea6f1cb988d950d340d75fedb16aeece69a.zip
Notes
Diffstat (limited to 'security/rain')
-rw-r--r--security/rain/Makefile27
-rw-r--r--security/rain/distinfo1
-rw-r--r--security/rain/files/patch-Makefile.in11
-rw-r--r--security/rain/pkg-comment1
-rw-r--r--security/rain/pkg-descr9
-rw-r--r--security/rain/pkg-plist8
6 files changed, 57 insertions, 0 deletions
diff --git a/security/rain/Makefile b/security/rain/Makefile
new file mode 100644
index 000000000000..c74756a414ba
--- /dev/null
+++ b/security/rain/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rain
+# Date created: Sun Jul 29 10:25:08 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rain
+PORTVERSION= 1.2.7.b3
+CATEGORIES= security net
+MASTER_SITES= http://www.tenebrous.com/rain/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/7.b/7b/}
+
+MAINTAINER= pat@databits.net
+
+GNU_CONFIGURE= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/rain ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in BUGS CHANGES DISCLAIMER README TODO doc/EXAMPLES
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/rain/distinfo b/security/rain/distinfo
new file mode 100644
index 000000000000..43052cdbc015
--- /dev/null
+++ b/security/rain/distinfo
@@ -0,0 +1 @@
+MD5 (rain-1.2.7b3.tar.gz) = fa5bb08b5e6e6ad18277a6601c3272fc
diff --git a/security/rain/files/patch-Makefile.in b/security/rain/files/patch-Makefile.in
new file mode 100644
index 000000000000..618d8cfac262
--- /dev/null
+++ b/security/rain/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Jul 29 10:30:31 2001
++++ Makefile.in Sun Jul 29 10:31:19 2001
+@@ -5,7 +5,7 @@
+ RAIN_PLATFORM=@host@
+ RAIN_VERSION="1.2.7beta3"
+ RAIN_URL=http://www.tenebrous.com/rain
+-CFLAGS= -g -Wall -I./include -DHAVE_CONFIG_H -D_GNU_SOURCE -DRAIN_PLATFORM=\"$(RAIN_PLATFORM)\" -DRAIN_VERSION=\"$(RAIN_VERSION)\" -DRAIN_URL=\"$(RAIN_URL)\"
++CFLAGS += -Wall -I./include -DHAVE_CONFIG_H -D_GNU_SOURCE -DRAIN_PLATFORM=\"$(RAIN_PLATFORM)\" -DRAIN_VERSION=\"$(RAIN_VERSION)\" -DRAIN_URL=\"$(RAIN_URL)\"
+ INSTALLER=@INSTALL@
+ MAKE=@SET_MAKE@
+
diff --git a/security/rain/pkg-comment b/security/rain/pkg-comment
new file mode 100644
index 000000000000..a1d9d2d3d294
--- /dev/null
+++ b/security/rain/pkg-comment
@@ -0,0 +1 @@
+Rain is a packeting tool used for testing system stability
diff --git a/security/rain/pkg-descr b/security/rain/pkg-descr
new file mode 100644
index 000000000000..dd78c0b959de
--- /dev/null
+++ b/security/rain/pkg-descr
@@ -0,0 +1,9 @@
+Rain is powerful tool for testing stability of hardware and software
+utilizing IP protocols. It offers its users the capability of
+creating their own packets with a wide variety of command line
+options.
+
+WWW: http://www.tenebrous.com/rain/
+Author: Michael Behan <mystic@tenebrous.com>
+
+- Patrick Li <pat@databits.net>
diff --git a/security/rain/pkg-plist b/security/rain/pkg-plist
new file mode 100644
index 000000000000..873f9e9502b8
--- /dev/null
+++ b/security/rain/pkg-plist
@@ -0,0 +1,8 @@
+bin/rain
+%%PORTDOCS%%share/doc/rain/BUGS
+%%PORTDOCS%%share/doc/rain/CHANGES
+%%PORTDOCS%%share/doc/rain/DISCLAIMER
+%%PORTDOCS%%share/doc/rain/EXAMPLES
+%%PORTDOCS%%share/doc/rain/README
+%%PORTDOCS%%share/doc/rain/TODO
+%%PORTDOCS%%@dirrm share/doc/rain