aboutsummaryrefslogtreecommitdiff
path: root/security/rarcrack/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-29 22:57:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-29 22:57:12 +0000
commitb5d6c545e43e8e1b01927f3da4f162681c546ba4 (patch)
treec40a6de462043321b37c8a03c9e81528666d9d43 /security/rarcrack/Makefile
parent6b4c3b8b1c36c2fe4e782b4becef440daa667de8 (diff)
downloadports-b5d6c545e43e8e1b01927f3da4f162681c546ba4.tar.gz
ports-b5d6c545e43e8e1b01927f3da4f162681c546ba4.zip
Notes
Diffstat (limited to 'security/rarcrack/Makefile')
-rw-r--r--security/rarcrack/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/rarcrack/Makefile b/security/rarcrack/Makefile
new file mode 100644
index 000000000000..f193f136f4db
--- /dev/null
+++ b/security/rarcrack/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: snoopy
+# Date created: 24 October 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+# $FreeBSD$
+
+PORTNAME= rarcrack
+PORTVERSION= 0.2
+CATEGORIES= security
+MASTER_SITES= SF
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= It's try to guess your encrypted compressed file's password
+
+RUN_DEPENDS= p7zip:${PORTSDIR}/archivers/p7zip \
+ unrar:${PORTSDIR}/archivers/unrar \
+ unzip:${PORTSDIR}/archivers/unzip
+
+USE_BZIP2= yes
+PLIST_FILES= bin/rarcrack
+PORTDOCS= README
+USE_GNOME= libxml2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rarcrack ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>