aboutsummaryrefslogtreecommitdiff
path: root/security/rats
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-08-23 09:03:03 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-08-23 09:03:03 +0000
commitd4fe05ed2c9eab4c8b7e34c40f3c3506175f92c0 (patch)
tree8bda712bc94c56044b9fa9c3174e86aab23d8c85 /security/rats
parent9656794eb2b3c2ade611e49252ecf9805b7bfaa5 (diff)
downloadports-d4fe05ed2c9eab4c8b7e34c40f3c3506175f92c0.tar.gz
ports-d4fe05ed2c9eab4c8b7e34c40f3c3506175f92c0.zip
Notes
Diffstat (limited to 'security/rats')
-rw-r--r--security/rats/Makefile29
-rw-r--r--security/rats/distinfo3
-rw-r--r--security/rats/pkg-comment1
-rw-r--r--security/rats/pkg-descr11
-rw-r--r--security/rats/pkg-plist6
5 files changed, 50 insertions, 0 deletions
diff --git a/security/rats/Makefile b/security/rats/Makefile
new file mode 100644
index 000000000000..53c127959327
--- /dev/null
+++ b/security/rats/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: rats
+# Date created: 22 August 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rats
+PORTVERSION= 1.1
+CATEGORIES= devel security
+MASTER_SITES= http://www.securesw.com/rats/
+
+MAINTAINER= kris@FreeBSD.org
+
+LIB_DEPENDS= expat.1:${PORTSDIR}/textproc/expat
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-expat-lib=${LOCALBASE}/lib \
+ --with-expat-include=${LOCALBASE}/include/xml
+
+ALL_TARGET= rats
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/rats
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rats
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/rats/distinfo b/security/rats/distinfo
new file mode 100644
index 000000000000..66fcc2710bff
--- /dev/null
+++ b/security/rats/distinfo
@@ -0,0 +1,3 @@
+MD5 (rats-1.1.tar.gz) = 39bd3a5f9bdecff15b0fec0c1bb5203a
+RMD160 (rats-1.1.tar.gz) = c944b3a74ed4e73e423c0e477ce2babe9f6efffa
+SHA1 (rats-1.1.tar.gz) = 80d7585299c370986b5caa4bff69b29545a668b8
diff --git a/security/rats/pkg-comment b/security/rats/pkg-comment
new file mode 100644
index 000000000000..c01d93cfaf98
--- /dev/null
+++ b/security/rats/pkg-comment
@@ -0,0 +1 @@
+Source code auditing tool
diff --git a/security/rats/pkg-descr b/security/rats/pkg-descr
new file mode 100644
index 000000000000..85fcef1337b2
--- /dev/null
+++ b/security/rats/pkg-descr
@@ -0,0 +1,11 @@
+This is RATS, a rough auditing tool for security, developed by
+Secure Software Solutions. It is a tool for scanning source code
+(C, C++, Perl, and Python) and flagging common security related
+programming errors such as buffer overflows and TOCTOU (Time Of
+Check, Time Of Use) race conditions. As its name implies, the tool
+performs only a rough analysis of source code. It will not find
+every error and will also find things that are not errors. Manual
+inspection of your code is still necessary, but greatly aided with
+this tool.
+
+WWW: http://www.securesw.com/rats/
diff --git a/security/rats/pkg-plist b/security/rats/pkg-plist
new file mode 100644
index 000000000000..0b9058d30a04
--- /dev/null
+++ b/security/rats/pkg-plist
@@ -0,0 +1,6 @@
+bin/rats
+lib/rats-c.xml
+lib/rats-perl.xml
+lib/rats-python.xml
+%%PORTDOCS%%share/doc/rats/README
+%%PORTDOCS%%@dirrm share/doc/rats