aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-dispatcher/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-11 02:20:53 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-11 02:20:53 +0000
commit849135e9c63ac7059977d6e8e33e32ce54c6f13e (patch)
tree4d07bdedff64f0daf781d2de76294ee50f1ec640 /security/razorback-dispatcher/Makefile
parent6389f5c857e2bbefb515a0ac780044cd73bffb4c (diff)
downloadports-849135e9c63ac7059977d6e8e33e32ce54c6f13e.tar.gz
ports-849135e9c63ac7059977d6e8e33e32ce54c6f13e.zip
Notes
Diffstat (limited to 'security/razorback-dispatcher/Makefile')
-rw-r--r--security/razorback-dispatcher/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/security/razorback-dispatcher/Makefile b/security/razorback-dispatcher/Makefile
new file mode 100644
index 000000000000..90b8c7c171db
--- /dev/null
+++ b/security/razorback-dispatcher/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: razorback-dispatcher
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dispatcher
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Dispatcher
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - Dispatcher
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api \
+ memcached:${PORTSDIR}/databases/libmemcached \
+ cli:${PORTSDIR}/devel/libcli
+
+OPTIONS_DEFINE= DEBUG ASSERT ACTIVEMQ
+OPTIONS_DEFAULT=ACTIVEMQ
+ASSERT_DESC= Enable Asserts
+ACTIVEMQ_DESC= ActiveMQ runs locally
+
+.include <bsd.port.options.mk>
+
+USE_GNOME= gnomehack
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USE_MYSQL= yes
+USE_RC_SUBR= dispatcher dispatcher_safed
+SUB_FILES= pkg-message
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USERS?= razorback
+GROUPS?= razorback
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MASSERT}
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+.if ${PORT_OPTIONS:MACTIVEMQ}
+RUN_DEPENDS= ${LOCALBASE}/etc/rc.d/activemq:${PORTSDIR}/net/activemq
+SUB_LIST= ACTIVEMQ="activemq " ACTIVEMQ_LOC="local" \
+ ACTIVEMQ_LOCATION="in the ActiveMQ configuration directory:" \
+ ACTIVEMQ_CONFIG="${LOCALBASE}/etc/activemq/"
+.else
+SUB_LIST= ACTIVEMQ="" ACTIVEMQ_LOC="remote" \
+ ACTIVEMQ_LOCATION="on the remote ActiveMQ host." \
+ ACTIVEMQ_CONFIG=""
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/razorback/dispatcher.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/dispatcher.conf.sample ${PREFIX}/etc/razorback/dispatcher.conf ; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>