aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-fsWalk/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-01 14:34:09 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-01 14:34:09 +0000
commite7b17c2e881c66af0468258215ee976695158201 (patch)
treed07ba4ee7f991680bb4fa1f661831037e8112fac /security/razorback-fsWalk/Makefile
parent28819e361168c40ba0f590441f2eb21686c8a798 (diff)
downloadports-e7b17c2e881c66af0468258215ee976695158201.tar.gz
ports-e7b17c2e881c66af0468258215ee976695158201.zip
Notes
Diffstat (limited to 'security/razorback-fsWalk/Makefile')
-rw-r--r--security/razorback-fsWalk/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/security/razorback-fsWalk/Makefile b/security/razorback-fsWalk/Makefile
new file mode 100644
index 000000000000..4650144ab0e2
--- /dev/null
+++ b/security/razorback-fsWalk/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: razorback-fsWalk
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fsWalk
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - File System Walker
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
+
+OPTIONS= DEBUG "Enable Debug" off \
+ ASSERT "Enable Asserts" off
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if defined(WITH_ASSERT)
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/razorback/fsWalk.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/fsWalk.conf.sample ${PREFIX}/etc/razorback/fsWalk.conf ; \
+ fi
+
+.include <bsd.port.mk>