aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-fsWalk
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2012-06-01 18:20:26 +0000
committerTom Judge <tj@FreeBSD.org>2012-06-01 18:20:26 +0000
commit1d14744cb6988531a48fb2b287c484d0972aba7b (patch)
tree490f4497cd69387468c22104e8e3f60b3ccaf530 /security/razorback-fsWalk
parent0acab13d73e190b2860ab89369139764c7d2a937 (diff)
downloadports-1d14744cb6988531a48fb2b287c484d0972aba7b.tar.gz
ports-1d14744cb6988531a48fb2b287c484d0972aba7b.zip
Convert to OptionsNG framework.
Approved by: eadler (mentor)
Notes
Notes: svn path=/head/; revision=297970
Diffstat (limited to 'security/razorback-fsWalk')
-rw-r--r--security/razorback-fsWalk/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/razorback-fsWalk/Makefile b/security/razorback-fsWalk/Makefile
index 4650144ab0e2..666b2c20d3a9 100644
--- a/security/razorback-fsWalk/Makefile
+++ b/security/razorback-fsWalk/Makefile
@@ -20,19 +20,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
-OPTIONS= DEBUG "Enable Debug" off \
- ASSERT "Enable Asserts" off
+OPTIONS_DEFINE= DEBUG ASSERT
+
+.include <bsd.port.options.mk>
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITH_DEBUG)
+.if !empty(PORT_OPTIONS:MDEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
-.if defined(WITH_ASSERT)
+.if !empty(PORT_OPTIONS:MASSERT)
CONFIGURE_ARGS+=--enable-assert
.endif