aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-scriptNugget
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-11 02:58:14 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-11 02:58:14 +0000
commitadb7cdd26fb3be08580f3bd0c189264f4040505f (patch)
treeee5bafb85db4f2fbd4a1d5450e564c2323fd2292 /security/razorback-scriptNugget
parent488be8b6ac13502a974b46b31b36b8c302109872 (diff)
downloadports-adb7cdd26fb3be08580f3bd0c189264f4040505f.tar.gz
ports-adb7cdd26fb3be08580f3bd0c189264f4040505f.zip
Notes
Diffstat (limited to 'security/razorback-scriptNugget')
-rw-r--r--security/razorback-scriptNugget/Makefile54
-rw-r--r--security/razorback-scriptNugget/distinfo2
-rw-r--r--security/razorback-scriptNugget/pkg-descr10
-rw-r--r--security/razorback-scriptNugget/pkg-plist14
4 files changed, 80 insertions, 0 deletions
diff --git a/security/razorback-scriptNugget/Makefile b/security/razorback-scriptNugget/Makefile
new file mode 100644
index 000000000000..a2121c36cabd
--- /dev/null
+++ b/security/razorback-scriptNugget/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: razorback-scriptNugget
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scriptNugget
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - Scripting Interface
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
+BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
+ rubygem-razorback-scriptNugget>=0.5.0:${PORTSDIR}/security/rubygem-razorback-scriptNugget
+
+OPTIONS_DEFINE= DEBUG ASSERT
+ASSERT_DESC= Enable Asserts
+
+.include <bsd.port.options.mk>
+
+RB_LIBDIR?= ${PREFIX}/lib/razorback
+USE_GNOME= libxml2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-ruby
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= ${RB_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MASSERT}
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ ${LN} -sf ${RB_LIBDIR}/scriptNugget.so.2 ${RB_LIBDIR}/scriptNugget.so.2.0.0
+ @if [ ! -f ${PREFIX}/etc/razorback/scriptNugget.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/scriptNugget.conf.sample ${PREFIX}/etc/razorback/scriptNugget.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-scriptNugget/distinfo b/security/razorback-scriptNugget/distinfo
new file mode 100644
index 000000000000..12e7cbfe8e27
--- /dev/null
+++ b/security/razorback-scriptNugget/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/scriptNugget-0.5.0.tar.gz) = bbea457e76051a90476169fe2008a84adaf0453d1cce6a0996498779db495d08
+SIZE (razorback/scriptNugget-0.5.0.tar.gz) = 324958
diff --git a/security/razorback-scriptNugget/pkg-descr b/security/razorback-scriptNugget/pkg-descr
new file mode 100644
index 000000000000..db80a93ea597
--- /dev/null
+++ b/security/razorback-scriptNugget/pkg-descr
@@ -0,0 +1,10 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+The scripting nugget uses XML across named pipes to pass registration,
+alerting and logging information back to the system. This allows the
+use of any scripting (or even compiled) language that can pass XML out
+STDOUT with Razorback.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-scriptNugget/pkg-plist b/security/razorback-scriptNugget/pkg-plist
new file mode 100644
index 000000000000..d2366f70f586
--- /dev/null
+++ b/security/razorback-scriptNugget/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+@unexec if cmp -s %D/etc/razorback/scriptNugget.conf %D/etc/razorback/scriptNugget.conf.sample; then rm -f %D/etc/razorback/scriptNugget.conf; fi
+etc/razorback/scriptNugget.conf.sample
+@exec if [ ! -f %D/etc/razorback/scriptNugget.conf ] ; then cp -p %D/%F %B/scriptNugget.conf; fi
+@dirrmtry etc/razorback
+lib/razorback/scriptNugget.so.2.0.0
+lib/razorback/scriptNugget.so.2
+lib/razorback/scriptNugget.so
+lib/razorback/scriptNugget.la
+lib/razorback/scriptNugget.a
+@dirrmtry lib/razorback
+libexec/razorback/scriptNugget/test.rb
+@dirrmtry libexec/razorback/scriptNugget
+@dirrmtry libexec/razorback