aboutsummaryrefslogtreecommitdiff
path: root/security/rc5pipe
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-26 17:21:51 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-26 17:21:51 +0000
commit7644d6375e9493f94270549c2746e02446340521 (patch)
tree72ffcd932378c6ef254bd6dc62d3b1b4c878b9b8 /security/rc5pipe
parent82367010fcc5d41de9b94094f50ecb9c7b0995cd (diff)
downloadports-7644d6375e9493f94270549c2746e02446340521.tar.gz
ports-7644d6375e9493f94270549c2746e02446340521.zip
Notes
Diffstat (limited to 'security/rc5pipe')
-rw-r--r--security/rc5pipe/Makefile21
-rw-r--r--security/rc5pipe/distinfo1
-rw-r--r--security/rc5pipe/files/patch-Makefile11
-rw-r--r--security/rc5pipe/pkg-comment1
-rw-r--r--security/rc5pipe/pkg-descr6
-rw-r--r--security/rc5pipe/pkg-plist1
6 files changed, 41 insertions, 0 deletions
diff --git a/security/rc5pipe/Makefile b/security/rc5pipe/Makefile
new file mode 100644
index 000000000000..44c1df5febd3
--- /dev/null
+++ b/security/rc5pipe/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: rc5pipe
+# Date created: 25 June 2002
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rc5pipe
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://krazykiwi.homeip.net/FreeBSD/ports/rc5pipe/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= frerich.raabe@gmx.de
+
+WRKSRC= ${WRKDIR}/rc5pipe
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rc5pipe ${PREFIX}/bin/rc5pipe
+
+.include <bsd.port.mk>
diff --git a/security/rc5pipe/distinfo b/security/rc5pipe/distinfo
new file mode 100644
index 000000000000..e3b32a92584c
--- /dev/null
+++ b/security/rc5pipe/distinfo
@@ -0,0 +1 @@
+MD5 (rc5pipe-1.1.tgz) = df7d4b5f1f74ed04060fce577acf637b
diff --git a/security/rc5pipe/files/patch-Makefile b/security/rc5pipe/files/patch-Makefile
new file mode 100644
index 000000000000..647cf93e542f
--- /dev/null
+++ b/security/rc5pipe/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Wed Jun 26 12:18:06 2002
++++ Makefile Wed Jun 26 12:18:32 2002
+@@ -1,6 +1,5 @@
+-CC=gcc
+-CFLAGS= -I/usr/local/include -s -O2
+-LIBS= -L/usr/local/lib
++CFLAGS+= -I${LOCALBASE}/include -s
++LIBS= -L${LOCALBASE}/lib
+
+ all:
+ $(CC) $(CFLAGS) -o rc5pipe rc5pipe.c $(LIBS)
diff --git a/security/rc5pipe/pkg-comment b/security/rc5pipe/pkg-comment
new file mode 100644
index 000000000000..23ab40147be0
--- /dev/null
+++ b/security/rc5pipe/pkg-comment
@@ -0,0 +1 @@
+RC5 en-/decryption via UNIX pipes
diff --git a/security/rc5pipe/pkg-descr b/security/rc5pipe/pkg-descr
new file mode 100644
index 000000000000..ff337d5c3206
--- /dev/null
+++ b/security/rc5pipe/pkg-descr
@@ -0,0 +1,6 @@
+rc5pipe is a security program for encrypting and decrypting text via UNIX
+pipes. It uses the 128-bit RC5 encryption algorithm and takes advantage of
+padding, and is especially useful if combined with netcat.
+
+- Frerich Raabe
+frerich.raabe@gmx.de
diff --git a/security/rc5pipe/pkg-plist b/security/rc5pipe/pkg-plist
new file mode 100644
index 000000000000..875d8b0558ea
--- /dev/null
+++ b/security/rc5pipe/pkg-plist
@@ -0,0 +1 @@
+bin/rc5pipe