aboutsummaryrefslogtreecommitdiff
path: root/security/revelation
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-08-31 19:44:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-08-31 19:44:17 +0000
commitd90758ea41ca30519a35860f2359c564d579ad2f (patch)
treedffab3d6e9cbd9b2acd3c381073b0b2a5444f796 /security/revelation
parent11164934f1a5b48fd5c2d6e7c8b04c48e7e48fb1 (diff)
downloadports-d90758ea41ca30519a35860f2359c564d579ad2f.tar.gz
ports-d90758ea41ca30519a35860f2359c564d579ad2f.zip
Notes
Diffstat (limited to 'security/revelation')
-rw-r--r--security/revelation/Makefile16
-rw-r--r--security/revelation/distinfo4
-rw-r--r--security/revelation/pkg-plist39
3 files changed, 35 insertions, 24 deletions
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
index 5db7def1a016..4d7306eb184e 100644
--- a/security/revelation/Makefile
+++ b/security/revelation/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= revelation
-PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTVERSION= 0.4.5
CATEGORIES= security gnome
MASTER_SITES= ftp://oss.codepoet.no/revelation/
@@ -24,16 +23,21 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= pygnome2 gnomeprefix gnomehack desktopfileutils
+USE_GNOME= pygnome2 pygnomeextras gnomeprefix gnomehack desktopfileutils
USE_PYTHON= yes
-GCONF_SCHEMAS= revelation.schemas
+GCONF_SCHEMAS= revelation.schemas revelation-applet.schemas
USE_REINPLACE= yes
+.if defined(PACKAGE_BUILDING)
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT} \
+ ${X11BASE}/lib/X11/fonts/misc/8x13O.pcf.gz:${X_FONTS_MISC_PORT}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|\(-Wl\)|$$(LDFLAGS) \1|' \
- ${WRKSRC}/wrap/crack/Makefile.in
+ ${WRKSRC}/src/wrap/crack/Makefile.in
@${REINPLACE_CMD} -e 's|#include <crack.h>||' \
- ${WRKSRC}/wrap/crack/crack.c.in
+ ${WRKSRC}/src/wrap/crack/crack.c.in
post-install:
-@update-desktop-database
diff --git a/security/revelation/distinfo b/security/revelation/distinfo
index e7f32e08cc23..92d8eca13fa5 100644
--- a/security/revelation/distinfo
+++ b/security/revelation/distinfo
@@ -1,2 +1,2 @@
-MD5 (revelation-0.4.3.tar.bz2) = 80c36c740c5e02da54f77da69800325a
-SIZE (revelation-0.4.3.tar.bz2) = 541292
+MD5 (revelation-0.4.5.tar.bz2) = f509367e8b5ab869fe00c6c3f87d2b58
+SIZE (revelation-0.4.5.tar.bz2) = 547303
diff --git a/security/revelation/pkg-plist b/security/revelation/pkg-plist
index 049ad2cd2842..26c50169ae10 100644
--- a/security/revelation/pkg-plist
+++ b/security/revelation/pkg-plist
@@ -4,6 +4,7 @@ bin/revelation
%%PYTHON_SITELIBDIR%%/revelation/datahandler/fpm.py
%%PYTHON_SITELIBDIR%%/revelation/datahandler/gpass.py
%%PYTHON_SITELIBDIR%%/revelation/datahandler/netrc.py
+%%PYTHON_SITELIBDIR%%/revelation/datahandler/pwsafe.py
%%PYTHON_SITELIBDIR%%/revelation/datahandler/rvl.py
%%PYTHON_SITELIBDIR%%/revelation/datahandler/text.py
%%PYTHON_SITELIBDIR%%/revelation/datahandler/xhtml.py
@@ -12,6 +13,7 @@ bin/revelation
%%PYTHON_SITELIBDIR%%/revelation/datahandler/fpm.pyc
%%PYTHON_SITELIBDIR%%/revelation/datahandler/gpass.pyc
%%PYTHON_SITELIBDIR%%/revelation/datahandler/netrc.pyc
+%%PYTHON_SITELIBDIR%%/revelation/datahandler/pwsafe.pyc
%%PYTHON_SITELIBDIR%%/revelation/datahandler/rvl.pyc
%%PYTHON_SITELIBDIR%%/revelation/datahandler/text.pyc
%%PYTHON_SITELIBDIR%%/revelation/datahandler/xhtml.pyc
@@ -20,6 +22,7 @@ bin/revelation
%%PYTHON_SITELIBDIR%%/revelation/datahandler/fpm.pyo
%%PYTHON_SITELIBDIR%%/revelation/datahandler/gpass.pyo
%%PYTHON_SITELIBDIR%%/revelation/datahandler/netrc.pyo
+%%PYTHON_SITELIBDIR%%/revelation/datahandler/pwsafe.pyo
%%PYTHON_SITELIBDIR%%/revelation/datahandler/rvl.pyo
%%PYTHON_SITELIBDIR%%/revelation/datahandler/text.pyo
%%PYTHON_SITELIBDIR%%/revelation/datahandler/xhtml.pyo
@@ -34,7 +37,6 @@ bin/revelation
%%PYTHON_SITELIBDIR%%/revelation/util.py
%%PYTHON_SITELIBDIR%%/revelation/__init__.pyc
%%PYTHON_SITELIBDIR%%/revelation/config.pyc
-%%PYTHON_SITELIBDIR%%/revelation/crack.so
%%PYTHON_SITELIBDIR%%/revelation/data.pyc
%%PYTHON_SITELIBDIR%%/revelation/dialog.pyc
%%PYTHON_SITELIBDIR%%/revelation/entry.pyc
@@ -49,29 +51,34 @@ bin/revelation
%%PYTHON_SITELIBDIR%%/revelation/io.pyo
%%PYTHON_SITELIBDIR%%/revelation/ui.pyo
%%PYTHON_SITELIBDIR%%/revelation/util.pyo
-%%PYTHON_SITELIBDIR%%/revelation/authmanager.so
+%%PYTHON_SITELIBDIR%%/revelation/crack.so
+%%PYTHON_SITELIBDIR%%/revelation/gnomemisc.so
@dirrm %%PYTHON_SITELIBDIR%%/revelation
@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2> /dev/null || true
@unexec rmdir %D/%%PYTHON_LIBDIR%% 2> /dev/null || true
+libdata/bonobo/servers/GNOME_RevelationApplet.server
+libexec/revelation-applet
share/gnome/applications/revelation.desktop
-share/mime/packages/revelation.xml
-@exec update-desktop-database > /dev/null || /usr/bin/true
-@unexec update-desktop-database > /dev/null || /usr/bin/true
+share/gnome/revelation/pwdict.hwm
+share/gnome/revelation/pwdict.pwd
+share/gnome/revelation/pwdict.pwi
+share/gnome/revelation/ui/actions.xml
+share/gnome/revelation/ui/menubar.xml
+share/gnome/revelation/ui/popup-tree.xml
+share/gnome/revelation/ui/toolbar.xml
+@dirrm share/gnome/revelation/ui
+@dirrm share/gnome/revelation
share/icons/hicolor/16x16/apps/revelation.png
share/icons/hicolor/24x24/apps/revelation.png
+share/icons/hicolor/24x24/apps/revelation-locked.png
share/icons/hicolor/32x32/apps/revelation.png
+share/icons/hicolor/32x32/apps/revelation-locked.png
share/icons/hicolor/48x48/apps/revelation.png
+share/icons/hicolor/48x48/apps/revelation-locked.png
share/icons/hicolor/48x48/mimetypes/gnome-mime-application-x-revelation.png
share/icons/hicolor/scalable/filesystems/revelation-fallback-folder.svg
share/icons/hicolor/scalable/filesystems/revelation-fallback-folder-open.svg
-@exec update-mime-database %D/share/mime
-@unexec update-mime-database %D/share/mime
-share/gnome/revelation/ui/actions.xml
-share/gnome/revelation/ui/menubar.xml
-share/gnome/revelation/ui/popup-tree.xml
-share/gnome/revelation/ui/toolbar.xml
-@dirrm share/gnome/revelation/ui
-share/gnome/revelation/pwdict.hwm
-share/gnome/revelation/pwdict.pwd
-share/gnome/revelation/pwdict.pwi
-@dirrm share/gnome/revelation
+share/mime/packages/revelation.xml
+share/mime/application/x-revelation.xml
+@exec update-desktop-database > /dev/null || /usr/bin/true
+@unexec update-desktop-database > /dev/null || /usr/bin/true