aboutsummaryrefslogtreecommitdiff
path: root/security/rifiuti2
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-20 17:13:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-20 17:13:51 +0000
commit4de9a02efbd701b05bfaadd2b1151d4e5603f580 (patch)
tree0f084cdcd0ef48d6aad8a5785172281aa78ad7ed /security/rifiuti2
parentf0d690b91a7b0dc268bf299aa9d72647760b0852 (diff)
downloadports-4de9a02efbd701b05bfaadd2b1151d4e5603f580.tar.gz
ports-4de9a02efbd701b05bfaadd2b1151d4e5603f580.zip
Notes
Diffstat (limited to 'security/rifiuti2')
-rw-r--r--security/rifiuti2/Makefile42
-rw-r--r--security/rifiuti2/distinfo2
-rw-r--r--security/rifiuti2/pkg-descr6
3 files changed, 50 insertions, 0 deletions
diff --git a/security/rifiuti2/Makefile b/security/rifiuti2/Makefile
new file mode 100644
index 000000000000..c4d9341b147b
--- /dev/null
+++ b/security/rifiuti2/Makefile
@@ -0,0 +1,42 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= rifiuti2
+DISTVERSION= 0.5.1
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Tool for analyzing Windows recycle bin
+
+LICENSE= BSD
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_GNOME= glib20
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/rifiuti bin/rifiuti-vista
+
+MAN1= rifiuti.1
+MLINKS= rifiuti.1 rifiuti-vista.1
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README THANKS TODO
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/rifiuti2/distinfo b/security/rifiuti2/distinfo
new file mode 100644
index 000000000000..b147817ac28e
--- /dev/null
+++ b/security/rifiuti2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rifiuti2-0.5.1.tar.gz) = b8db7d9ff442d71794256a97103134200b286c19134f2fe30506f58035a380b2
+SIZE (rifiuti2-0.5.1.tar.gz) = 109598
diff --git a/security/rifiuti2/pkg-descr b/security/rifiuti2/pkg-descr
new file mode 100644
index 000000000000..ce29539e9e58
--- /dev/null
+++ b/security/rifiuti2/pkg-descr
@@ -0,0 +1,6 @@
+rifiuti2 is a rewrite of rifiuti, a great tool from Foundstone folks
+for analyzing Windows Recycle Bin INFO2 file. But since rifiuti
+(last updated 2004) is restricted to English version of Windows
+(fail to analyze any non-latin character), thus this rewrite.
+
+WWW: http://code.google.com/p/rifiuti2/