aboutsummaryrefslogtreecommitdiff
path: root/security/rkhunter
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-25 21:23:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-25 21:23:48 +0000
commit18fa8363e2dd66249614a1a74591e780b2019b76 (patch)
tree126cd63023ed3ef56a0ed62034719db6face23d2 /security/rkhunter
parentdb26f1e7218eadd1b59bf06cdf28f1243bd2ad19 (diff)
downloadports-18fa8363e2dd66249614a1a74591e780b2019b76.tar.gz
ports-18fa8363e2dd66249614a1a74591e780b2019b76.zip
Notes
Diffstat (limited to 'security/rkhunter')
-rw-r--r--security/rkhunter/Makefile36
-rw-r--r--security/rkhunter/distinfo4
-rw-r--r--security/rkhunter/files/patch-installer.sh86
-rw-r--r--security/rkhunter/files/patch-rkhunter.conf11
-rw-r--r--security/rkhunter/files/pkg-message.in7
-rw-r--r--security/rkhunter/pkg-descr7
-rw-r--r--security/rkhunter/pkg-plist19
7 files changed, 144 insertions, 26 deletions
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
index 34d9f045ea18..1cfdc50e306b 100644
--- a/security/rkhunter/Makefile
+++ b/security/rkhunter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rkhunter
-PORTVERSION= 1.0.8
+PORTVERSION= 1.1.3
CATEGORIES= security
MASTER_SITES= http://downloads.rootkit.nl/
@@ -19,31 +19,23 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PERL5= yes
NO_BUILD= yes
USE_REINPLACE= yes
-
-PLIST_DIRS= rkhunter/scripts rkhunter/db rkhunter/docs rkhunter/tmp rkhunter
-PLIST_FILES= rkhunter/scripts/check_modules.pl \
- rkhunter/scripts/check_port.pl \
- rkhunter/scripts/filehashmd5.pl \
- rkhunter/scripts/filehashsha1.pl \
- bin/rkhunter \
- etc/rkhunter.conf \
- rkhunter/scripts/showfiles.pl \
- rkhunter/db/backdoorports.dat \
- rkhunter/db/mirrors.dat \
- rkhunter/db/os.dat \
- rkhunter/db/defaulthashes.dat \
- rkhunter/db/md5blacklist.dat \
- rkhunter/docs/CHANGELOG \
- rkhunter/docs/README \
- rkhunter/docs/WISHLIST
+PKGMESSAGE= ${WRKDIR}/pkg-message
MAN8= rkhunter.8
MANCOMPRESSED= no
-pre-install:
- ${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g" ${WRKSRC}/installer.sh
+post-patch:
+ @${SED} -e 's|PREFIX|${PREFIX}|g' ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+
do-install:
- cd ${WRKSRC} && ./installer.sh
- ${INSTALL_MAN} ${WRKSRC}/files/development/rkhunter.8 ${MAN8PREFIX}/man/man8
+ cd ${WRKSRC} && ./installer.sh --installdir ${PREFIX}
+ ${INSTALL_MAN} ${WRKSRC}/files/development/rkhunter.8 ${MAN8PREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/files/CHANGELOG ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/files/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/files/WISHLIST ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/security/rkhunter/distinfo b/security/rkhunter/distinfo
index b70a9ebafa27..daa97e9fb771 100644
--- a/security/rkhunter/distinfo
+++ b/security/rkhunter/distinfo
@@ -1,2 +1,2 @@
-MD5 (rkhunter-1.0.8.tar.gz) = bc1006d36e5b2674985c9396b5c46c95
-SIZE (rkhunter-1.0.8.tar.gz) = 77582
+MD5 (rkhunter-1.1.3.tar.gz) = 62271204de0fa0d2bf1b8489b1458dc7
+SIZE (rkhunter-1.1.3.tar.gz) = 98309
diff --git a/security/rkhunter/files/patch-installer.sh b/security/rkhunter/files/patch-installer.sh
new file mode 100644
index 000000000000..efbe57d1fe99
--- /dev/null
+++ b/security/rkhunter/files/patch-installer.sh
@@ -0,0 +1,86 @@
+--- installer.sh.orig Sun Jul 25 16:20:28 2004
++++ installer.sh Sun Jul 25 17:19:48 2004
+@@ -69,6 +69,7 @@
+ ;;
+ *)
+ echo "Wrong parameter"
++ exit
+ ;;
+ esac
+ shift
+@@ -111,21 +112,18 @@
+ overwrite:check_port.pl:/scripts/check_port.pl:Portscanner
+ overwrite:filehashmd5.pl:/scripts/filehashmd5.pl:MD5%%Digest%%generator
+ overwrite:filehashsha1.pl:/scripts/filehashsha1.pl:SHA1%%Digest%%generator
+-verwrite:showfiles.pl:/scripts/showfiles.pl:Directory%%viewer
++overwrite:showfiles.pl:/scripts/showfiles.pl:Directory%%viewer
+ overwrite:backdoorports.dat:/db/backdoorports.dat:Database%%Backdoor%%ports
+ overwrite:mirrors.dat:/db/mirrors.dat:Database%%Update%%mirrors
+ overwrite:os.dat:/db/os.dat:Database%%Operating%%Systems
+ overwrite:defaulthashes.dat:/db/defaulthashes.dat:Database%%Default%%file%%hashes
+ overwrite:md5blacklist.dat:/db/md5blacklist.dat:Database%%MD5%%blacklisted%%files
+-overwrite:CHANGELOG:/docs/CHANGELOG:Changelog
+-overwrite:README:/docs/README:Readme%%and%%FAQ
+-overwrite:WISHLIST:/docs/WISHLIST:Wishlist%%and%%TODO
+ "
+
+ # Prefix: INSTALLDIR
+ INSTALLFILES2="
+-overwrite:rkhunter.conf:/usr/local/etc/rkhunter.conf:RK%%Hunter%%configuration%%file
+-overwrite:rkhunter:/usr/local/bin/rkhunter:RK%%Hunter%%binary
++overwrite:rkhunter.conf:/etc/rkhunter.conf.sample:RK%%Hunter%%configuration%%file
++overwrite:rkhunter:/bin/rkhunter:RK%%Hunter%%binary
+ "
+
+ # Create directories (only if they do not exist)
+@@ -134,10 +132,7 @@
+ ${INSTALLDIR}/etc
+ ${INSTALLDIR}/bin
+ ${INSTALLDIR}/lib/rkhunter/db
+-${INSTALLDIR}/lib/rkhunter/docs
+ ${INSTALLDIR}/lib/rkhunter/scripts
+-${INSTALLDIR}/lib/rkhunter/tmp
+-/usr/local/etc
+ "
+
+ CHECKDIR="/usr/local"
+@@ -345,8 +340,6 @@
+
+
+ # Clean active window
+-clear
+-
+ echo "${INSTALLER_NAME} ${INSTALLER_VERSION} (${INSTALLER_COPYRIGHT})"
+ echo $ECHOOPT "---------------"
+ echo "Starting installation/update"
+@@ -467,7 +460,7 @@
+ if [ -f ${INSTALLPREFIX}${CURFILE} ]
+ then
+ #error redirection in .rkhunter it's just for a clear display if user run not as root
+- cp -f ${INSTALLPREFIX}${CURFILE} ${NEWFILE} 2> ~/.rkhunter.log
++ cp -f ${INSTALLPREFIX}${CURFILE} "${INSTALLDIR}/${NEWFILE}" 2> ~/.rkhunter.log
+ if [ $? -eq 0 ]
+ then
+ echo $E "OK"
+@@ -482,10 +475,10 @@
+
+ done
+
+-INSTALLDIRCHECK=`cat /usr/local/etc/rkhunter.conf | grep "INSTALLDIR="`
++INSTALLDIRCHECK=`cat $INSTALLDIR/etc/rkhunter.conf.sample | grep "INSTALLDIR="`
+ if [ "${INSTALLDIRCHECK}" = "" ]
+ then
+- echo "INSTALLDIR=${INSTALLDIR}" >> /usr/local/etc/rkhunter.conf
++ echo "INSTALLDIR=${INSTALLDIR}" >> $INSTALLDIR/etc/rkhunter.conf.sample
+ echo "Configuration updated with installation path (${INSTALLDIR})"
+ else
+ echo "Configuration already updated."
+@@ -495,7 +488,7 @@
+ then
+ echo ""
+ echo $E "$t17"
+- echo "$t18 (/usr/local/bin/rkhunter)"
++ echo "$t18 (${INSTALLDIR}/bin/rkhunter)"
+ else
+ echo ""
+ echo $E "$t19"
diff --git a/security/rkhunter/files/patch-rkhunter.conf b/security/rkhunter/files/patch-rkhunter.conf
new file mode 100644
index 000000000000..63b7628460d9
--- /dev/null
+++ b/security/rkhunter/files/patch-rkhunter.conf
@@ -0,0 +1,11 @@
+--- files/rkhunter.conf.orig Sun Jul 25 17:08:25 2004
++++ files/rkhunter.conf Sun Jul 25 17:08:48 2004
+@@ -8,7 +8,7 @@
+
+ # Use a custom temporary directory (you can override it with the
+ # --tmpdir parameter)
+-#TMPDIR=/tmp
++TMPDIR=/tmp
+
+ # Use a custom database directory (you can override it with the
+ # --dbdir parameter)
diff --git a/security/rkhunter/files/pkg-message.in b/security/rkhunter/files/pkg-message.in
new file mode 100644
index 000000000000..18459e773237
--- /dev/null
+++ b/security/rkhunter/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+#############################################################################
+ Installed additional documentation in: PREFIX/share/doc/rkhunter
+ Copy PREFIX/etc/rkhunter.conf.sample to PREFIX/etc/rkhunter.conf
+#############################################################################
+
+
diff --git a/security/rkhunter/pkg-descr b/security/rkhunter/pkg-descr
index cf3dac6179fa..37013c2c45b8 100644
--- a/security/rkhunter/pkg-descr
+++ b/security/rkhunter/pkg-descr
@@ -1,5 +1,5 @@
Rootkit Hunter is scanning tool to ensure you for about 99.9% you're
-clean of nasty tools.
+clean of nasty tools.
This tool scans for rootkits, backdoors and local exploits by running
tests like:
@@ -11,4 +11,7 @@ tests like:
- Look for hidden files
- Optional scan within plaintext and binary files
-WWW: http://www.rootkit.nl/
+WWW: http://www.rootkit.nl/
+
+- bugghy
+bugghy@SAFe-mail.net
diff --git a/security/rkhunter/pkg-plist b/security/rkhunter/pkg-plist
new file mode 100644
index 000000000000..3fc144980390
--- /dev/null
+++ b/security/rkhunter/pkg-plist
@@ -0,0 +1,19 @@
+etc/rkhunter.conf.sample
+bin/rkhunter
+lib/rkhunter/db/backdoorports.dat
+lib/rkhunter/db/mirrors.dat
+lib/rkhunter/db/os.dat
+lib/rkhunter/db/defaulthashes.dat
+lib/rkhunter/db/md5blacklist.dat
+lib/rkhunter/scripts/check_modules.pl
+lib/rkhunter/scripts/check_port.pl
+lib/rkhunter/scripts/filehashmd5.pl
+lib/rkhunter/scripts/filehashsha1.pl
+lib/rkhunter/scripts/showfiles.pl
+@dirrm lib/rkhunter/scripts
+@dirrm lib/rkhunter/db
+@dirrm lib/rkhunter
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/WISHLIST
+%%PORTDOCS%%@dirrm %%DOCSDIR%%