aboutsummaryrefslogtreecommitdiff
path: root/security/rkhunter
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-15 14:00:59 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-15 14:00:59 +0000
commitd1cfa44f005c7183819d450d9c985b0cfd204181 (patch)
treeb6933827f2b9ca61b96ef26237dcd4200cd3af40 /security/rkhunter
parent3538dd0e93298342b0e6c0a57be6cd23771ac299 (diff)
downloadports-d1cfa44f005c7183819d450d9c985b0cfd204181.tar.gz
ports-d1cfa44f005c7183819d450d9c985b0cfd204181.zip
Notes
Diffstat (limited to 'security/rkhunter')
-rw-r--r--security/rkhunter/Makefile49
-rw-r--r--security/rkhunter/distinfo2
-rw-r--r--security/rkhunter/pkg-descr14
3 files changed, 65 insertions, 0 deletions
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
new file mode 100644
index 000000000000..34d9f045ea18
--- /dev/null
+++ b/security/rkhunter/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: rkhunter
+# Date created: 15 May 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= rkhunter
+PORTVERSION= 1.0.8
+CATEGORIES= security
+MASTER_SITES= http://downloads.rootkit.nl/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Rootkit detection tool
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_PERL5= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+PLIST_DIRS= rkhunter/scripts rkhunter/db rkhunter/docs rkhunter/tmp rkhunter
+PLIST_FILES= rkhunter/scripts/check_modules.pl \
+ rkhunter/scripts/check_port.pl \
+ rkhunter/scripts/filehashmd5.pl \
+ rkhunter/scripts/filehashsha1.pl \
+ bin/rkhunter \
+ etc/rkhunter.conf \
+ rkhunter/scripts/showfiles.pl \
+ rkhunter/db/backdoorports.dat \
+ rkhunter/db/mirrors.dat \
+ rkhunter/db/os.dat \
+ rkhunter/db/defaulthashes.dat \
+ rkhunter/db/md5blacklist.dat \
+ rkhunter/docs/CHANGELOG \
+ rkhunter/docs/README \
+ rkhunter/docs/WISHLIST
+
+MAN8= rkhunter.8
+MANCOMPRESSED= no
+
+pre-install:
+ ${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g" ${WRKSRC}/installer.sh
+do-install:
+ cd ${WRKSRC} && ./installer.sh
+ ${INSTALL_MAN} ${WRKSRC}/files/development/rkhunter.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/security/rkhunter/distinfo b/security/rkhunter/distinfo
new file mode 100644
index 000000000000..b70a9ebafa27
--- /dev/null
+++ b/security/rkhunter/distinfo
@@ -0,0 +1,2 @@
+MD5 (rkhunter-1.0.8.tar.gz) = bc1006d36e5b2674985c9396b5c46c95
+SIZE (rkhunter-1.0.8.tar.gz) = 77582
diff --git a/security/rkhunter/pkg-descr b/security/rkhunter/pkg-descr
new file mode 100644
index 000000000000..cf3dac6179fa
--- /dev/null
+++ b/security/rkhunter/pkg-descr
@@ -0,0 +1,14 @@
+Rootkit Hunter is scanning tool to ensure you for about 99.9% you're
+clean of nasty tools.
+
+This tool scans for rootkits, backdoors and local exploits by running
+tests like:
+
+- MD5/SHA1 hash compare
+- Look for default files used by rootkits
+- Wrong file permissions for binaries
+- Look for suspected strings in LKM and KLD modules
+- Look for hidden files
+- Optional scan within plaintext and binary files
+
+WWW: http://www.rootkit.nl/