aboutsummaryrefslogtreecommitdiff
path: root/security/rndpassw
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-21 10:14:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-21 10:14:57 +0000
commit6ba73484aefc25880834a377d95a5aeb4d7078aa (patch)
treef0e8be3011df58b77e3c5fc1ca605f168d03ec09 /security/rndpassw
parent4ae72708d88ccdd897f8927e4cb51273e461123a (diff)
downloadports-6ba73484aefc25880834a377d95a5aeb4d7078aa.tar.gz
ports-6ba73484aefc25880834a377d95a5aeb4d7078aa.zip
Notes
Diffstat (limited to 'security/rndpassw')
-rw-r--r--security/rndpassw/Makefile5
-rw-r--r--security/rndpassw/files/patch-Makefile26
2 files changed, 28 insertions, 3 deletions
diff --git a/security/rndpassw/Makefile b/security/rndpassw/Makefile
index ffac827b5d4d..5953ba636d87 100644
--- a/security/rndpassw/Makefile
+++ b/security/rndpassw/Makefile
@@ -12,8 +12,7 @@ LICENSE= BSD
USE_BZIP2= yes
-MAN1= rndpassw.1
-PLIST_FILES= bin/rndpassw
+PLIST_FILES= bin/rndpassw \
+ man/man1/rndpassw.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/rndpassw/files/patch-Makefile b/security/rndpassw/files/patch-Makefile
new file mode 100644
index 000000000000..d99bf57e54a5
--- /dev/null
+++ b/security/rndpassw/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.org 2014-02-21 17:59:00.973237401 +0800
++++ Makefile 2014-02-21 17:59:53.848746216 +0800
+@@ -1,4 +1,4 @@
+-PREFIX?=/usr/local
++PREFIX?=$(DESTDIR)$(PREFIX)
+
+ CC?= cc
+ CFLAGS?=-O2 -fno-strict-aliasing -pipe
+@@ -18,11 +18,11 @@
+ @rm -f $(PROG) $(PROG).o
+
+ install: build
+- @install -d $(PREFIX)/bin
+- @install -d $(PREFIX)/man/man1
+- install -c $(PROG) $(PREFIX)/bin/$(PROG)
+- install -c $(PROG).1 $(PREFIX)/man/man1/$(PROG).1
++ @install -d $(DESTDIR)$(PREFIX)/bin
++ @install -d $(DESTDIR)$(PREFIX)/man/man1
++ install -c $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
++ install -c $(PROG).1 $(DESTDIR)$(PREFIX)/man/man1/$(PROG).1
+
+ uninstall:
+- rm -f $(PREFIX)/bin/$(PROG)
+- rm -f $(PREFIX)/man/man1/$(PROG).1.gz
++ rm -f $(DESTDIR)$(PREFIX)/bin/$(PROG)
++ rm -f $(DESTDIR)$(PREFIX)/man/man1/$(PROG).1.gz