aboutsummaryrefslogtreecommitdiff
path: root/security/rsaref
diff options
context:
space:
mode:
authorScott Mace <smace@FreeBSD.org>1998-09-15 14:49:08 +0000
committerScott Mace <smace@FreeBSD.org>1998-09-15 14:49:08 +0000
commit5a6b7d287c882f090a4480efaa3cc64132298cbe (patch)
tree7bccb4b101a382fea790ace5bf5e7bc9d328139b /security/rsaref
parentfaa36925ca10d168e7d5ff278a251a52533ba9f7 (diff)
downloadports-5a6b7d287c882f090a4480efaa3cc64132298cbe.tar.gz
ports-5a6b7d287c882f090a4480efaa3cc64132298cbe.zip
Notes
Diffstat (limited to 'security/rsaref')
-rw-r--r--security/rsaref/files/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/rsaref/files/Makefile b/security/rsaref/files/Makefile
index e1b2f25e434b..3cf51fbce8fb 100644
--- a/security/rsaref/files/Makefile
+++ b/security/rsaref/files/Makefile
@@ -21,5 +21,10 @@ $(RSAREFLIB) : desc.$(O) digit.$(O) md2c.$(O) md5c.$(O) nn.$(O) prime.$(O)\
$(SORSAREFLIB) : desc.$(SO) digit.$(SO) md2c.$(SO) md5c.$(SO) nn.$(SO) prime.$(SO)\
rsa.$(SO) r_encode.$(SO) r_dh.$(SO) r_enhanc.$(SO) r_keygen.$(SO) r_random.$(SO)\
r_stdlib.$(SO)
+.if defined(PORTOBJFORMAT) && PORTOBJFORMAT == elf
${CC} -o $@ -shared -Wl,-soname,$@ $>
+.else
+ ld -Bshareable -x -o $@ $>
+.endif
+