aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-camellia
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-13 07:26:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-13 07:26:06 +0000
commit991984ad3174059a1b042cacc1fb09d08f176d57 (patch)
tree48eee02c467cfe8fa7430322fcea610dc52c3890 /security/ruby-camellia
parent60d1e09951cf1b7beee24b309e808c40f0a84ac3 (diff)
downloadports-991984ad3174059a1b042cacc1fb09d08f176d57.tar.gz
ports-991984ad3174059a1b042cacc1fb09d08f176d57.zip
This is a Camellia package for Ruby. Camellia engine is implemented in "C".
Supported key length : 128bit/192bit/256bit Supported modes of operation : ECB/CFB/CBC WWW: http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html PR: ports/126390 Submitted by: Yoshisato YANAGISAWA <osho at pcc-software.org>
Notes
Notes: svn path=/head/; revision=218495
Diffstat (limited to 'security/ruby-camellia')
-rw-r--r--security/ruby-camellia/Makefile39
-rw-r--r--security/ruby-camellia/distinfo3
-rw-r--r--security/ruby-camellia/pkg-descr5
-rw-r--r--security/ruby-camellia/pkg-plist9
4 files changed, 56 insertions, 0 deletions
diff --git a/security/ruby-camellia/Makefile b/security/ruby-camellia/Makefile
new file mode 100644
index 000000000000..d6ebf0f35282
--- /dev/null
+++ b/security/ruby-camellia/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: camellia-rb
+# Date created: 9 August 2008
+# Whom: Yoshisato YANAGISAWA <osho@pcc-software.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= camellia
+PORTVERSION= 1.0
+CATEGORIES= security ruby
+MASTER_SITES= http://info.isl.ntt.co.jp/crypt/camellia/dl/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-rb-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= osho@pcc-software.org
+COMMENT= A Ruby extension library which implements Camellia encryption
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README.txt History.txt License.txt
+EXAMPLES= cext/camellia-example.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/ruby-camellia/distinfo b/security/ruby-camellia/distinfo
new file mode 100644
index 000000000000..c67ec0001b14
--- /dev/null
+++ b/security/ruby-camellia/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/camellia-rb-1.0.tar.gz) = f4f526581da8be672673d5268aa9bfe6
+SHA256 (ruby/camellia-rb-1.0.tar.gz) = 361cbcd7d7fadc30bf3a8a45efe687248ccaac5cd675b6c031e2ee97019422bf
+SIZE (ruby/camellia-rb-1.0.tar.gz) = 37442
diff --git a/security/ruby-camellia/pkg-descr b/security/ruby-camellia/pkg-descr
new file mode 100644
index 000000000000..1077521343d3
--- /dev/null
+++ b/security/ruby-camellia/pkg-descr
@@ -0,0 +1,5 @@
+This is a Camellia package for Ruby. Camellia engine is implemented in "C".
+Supported key length : 128bit/192bit/256bit
+Supported modes of operation : ECB/CFB/CBC
+
+WWW: http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html
diff --git a/security/ruby-camellia/pkg-plist b/security/ruby-camellia/pkg-plist
new file mode 100644
index 000000000000..6b8a324524bd
--- /dev/null
+++ b/security/ruby-camellia/pkg-plist
@@ -0,0 +1,9 @@
+%%RUBY_SITELIBDIR%%/camellia_rb.rb
+%%RUBY_SITELIBDIR%%/camellia_rb/version.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/History.txt
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/License.txt
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.txt
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/camellia-example.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+@dirrm %%RUBY_SITELIBDIR%%/camellia_rb