aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-openssl
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-20 11:50:24 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-20 11:50:24 +0000
commit6092cf2d58aff3d1c5a1230ec5d29264027e3d67 (patch)
treef936cc33391df7affe17aa13e55764143c41952c /security/ruby-openssl
parent448a67ccc2354d2e020e64ee01a121b0d56a6039 (diff)
downloadports-6092cf2d58aff3d1c5a1230ec5d29264027e3d67.tar.gz
ports-6092cf2d58aff3d1c5a1230ec5d29264027e3d67.zip
Notes
Diffstat (limited to 'security/ruby-openssl')
-rw-r--r--security/ruby-openssl/Makefile38
-rw-r--r--security/ruby-openssl/distinfo1
-rw-r--r--security/ruby-openssl/pkg-comment1
-rw-r--r--security/ruby-openssl/pkg-descr5
-rw-r--r--security/ruby-openssl/pkg-plist25
5 files changed, 70 insertions, 0 deletions
diff --git a/security/ruby-openssl/Makefile b/security/ruby-openssl/Makefile
new file mode 100644
index 000000000000..d873c782964c
--- /dev/null
+++ b/security/ruby-openssl/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Ruby/OpenSSL
+# Date created: 20 October 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openssl
+PORTVERSION= 0.0.3
+CATEGORIES= security ruby
+MASTER_SITES= http://klokan.sh.cvut.cz/~rokosm/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ossl-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_OPENSSL= yes
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+CONFIGURE_ARGS= --with-openssl-include="${OPENSSLBASE}/include/openssl" \
+ --with-openssl-lib="${OPENSSLBASE}/lib"
+INSTALL_TARGET= site-install
+
+post-extract:
+ find ${WRKSRC} -type d -name CVS | xargs ${RM} -rf
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/test/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/ruby-openssl/distinfo b/security/ruby-openssl/distinfo
new file mode 100644
index 000000000000..57ed661fbf07
--- /dev/null
+++ b/security/ruby-openssl/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ossl-0.0.3.tgz) = 29e83a5f4887234b780ad3d95e35f16b
diff --git a/security/ruby-openssl/pkg-comment b/security/ruby-openssl/pkg-comment
new file mode 100644
index 000000000000..fc8588500081
--- /dev/null
+++ b/security/ruby-openssl/pkg-comment
@@ -0,0 +1 @@
+A Ruby module which wraps OpenSSL
diff --git a/security/ruby-openssl/pkg-descr b/security/ruby-openssl/pkg-descr
new file mode 100644
index 000000000000..f86e740e2e69
--- /dev/null
+++ b/security/ruby-openssl/pkg-descr
@@ -0,0 +1,5 @@
+This is a Ruby module which wraps OpenSSL and provides access to the
+RSA/X509/Digest functions.
+
+Author: Michal Rokos <m.rokos@sh.cvut.cz>
+WWW: http://klokan.sh.cvut.cz/~rokosm/
diff --git a/security/ruby-openssl/pkg-plist b/security/ruby-openssl/pkg-plist
new file mode 100644
index 000000000000..bcda367fa4b3
--- /dev/null
+++ b/security/ruby-openssl/pkg-plist
@@ -0,0 +1,25 @@
+%%RUBY_SITEARCHLIBDIR%%/OpenSSL.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/01cert.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/01crl.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/01key.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/01pub.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/01req.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/02cert.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/02key.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/02req.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/cacert.pem
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/config.cnf
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/key_hash.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_config.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_digest.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_rsa.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_x509.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_x509crl.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_x509req.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/ossl_x509store.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/c/hash.c
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/openssl/c/key.c
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/openssl/c
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/openssl
+%%PORTDOCS%%%%RUBY_DOCDIR%%/openssl/README.txt
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/openssl