aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-password/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-19 20:05:56 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-19 20:05:56 +0000
commitef77b2bf81c60940af0a9aa42b5a14f5c61b8d33 (patch)
tree507f2c4a0314dcf418b5d10dd8f9b2b7c77916eb /security/ruby-password/Makefile
parent1bd6bcee7f7a9cda2c6cac420b81e1b12ac638fe (diff)
downloadports-ef77b2bf81c60940af0a9aa42b5a14f5c61b8d33.tar.gz
ports-ef77b2bf81c60940af0a9aa42b5a14f5c61b8d33.zip
Notes
Diffstat (limited to 'security/ruby-password/Makefile')
-rw-r--r--security/ruby-password/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/ruby-password/Makefile b/security/ruby-password/Makefile
new file mode 100644
index 000000000000..7b306c980f30
--- /dev/null
+++ b/security/ruby-password/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Ruby/Password
+# Date created: 18 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= password
+PORTVERSION= 0.2.0
+CATEGORIES= security ruby
+MASTER_SITES= http://www.caliban.org/files/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/termios.so:${PORTSDIR}/comms/ruby-termios
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+CONFIGURE_ARGS= --with-crack-dict="${LOCALBASE}/libdata/cracklib/pw_dict.pwd"
+INSTALL_TARGET= site-install
+
+DOCS_EN= CHANGES README doc/password.html
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>