aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-password
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-03 13:20:15 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-03 13:20:15 +0000
commita4c3b3b69d973561bfd056fc746d7e658cedb198 (patch)
treecd608b038e87d313994c563c51bf5dd12531e33a /security/ruby-password
parent2e5809345223c38265ead2c1ac6c5daa868183e2 (diff)
downloadports-a4c3b3b69d973561bfd056fc746d7e658cedb198.tar.gz
ports-a4c3b3b69d973561bfd056fc746d7e658cedb198.zip
Notes
Diffstat (limited to 'security/ruby-password')
-rw-r--r--security/ruby-password/Makefile17
-rw-r--r--security/ruby-password/distinfo6
-rw-r--r--security/ruby-password/pkg-plist10
3 files changed, 21 insertions, 12 deletions
diff --git a/security/ruby-password/Makefile b/security/ruby-password/Makefile
index 36f23482ea33..3f1f05ef2127 100644
--- a/security/ruby-password/Makefile
+++ b/security/ruby-password/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= password
-PORTVERSION= 0.5.2
+PORTVERSION= 0.5.3
CATEGORIES= security ruby
MASTER_SITES= http://www.caliban.org/files/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= A Ruby library to create, verify and manipulate passwords
BUILD_DEPENDS= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/termios.so:${PORTSDIR}/comms/ruby-termios
+RUN_DEPENDS= ${LOCALBASE}/${SADIR}/termios.so:${PORTSDIR}/comms/ruby-termios
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
RUBY_SHEBANG_FILES= example/*
+SADIR= lib/ruby/site_ruby/${RUBY_VER}/${RUBY_ARCH}
CONFIGURE_ARGS= --with-crack-dict="${LOCALBASE}/libdata/cracklib/pw_dict.pwd"
INSTALL_TARGET= site-install
@@ -31,16 +32,18 @@ MANCOMPRESSED= no
DOCS_EN= CHANGES README
+post-patch:
+ @${REINPLACE_CMD} -E -e 's,([^[:alpha:]]+)crack.h,\1packer.h,g' \
+ ${WRKSRC}/rbcrack.c ${WRKSRC}/extconf.rb
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/example/pwgen ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/pwgen.1 ${MANPREFIX}/man/man1/
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/example/*.rb ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/example/*.rb ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${DOCS_EN:S,^,${WRKSRC}/,} ${RUBY_MODDOCDIR}/
.endif
.include <bsd.port.mk>
diff --git a/security/ruby-password/distinfo b/security/ruby-password/distinfo
index 3015b1a1b4f4..64e341089646 100644
--- a/security/ruby-password/distinfo
+++ b/security/ruby-password/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/ruby-password-0.5.2.tar.gz) = 6a33fb9dd039f07fe2b81a0d8eed7f6f
-SHA256 (ruby/ruby-password-0.5.2.tar.gz) = 14c27d8421203b82bbe2442b704f3c04cd3437a3e5d66b75606a139801b95731
-SIZE (ruby/ruby-password-0.5.2.tar.gz) = 22656
+MD5 (ruby/ruby-password-0.5.3.tar.gz) = b4304bab359bdc95bc7f0938b0db4bed
+SHA256 (ruby/ruby-password-0.5.3.tar.gz) = 2563d30868f90ed958919b235668639678d4cdc259eeaad528a267ca456f224f
+SIZE (ruby/ruby-password-0.5.3.tar.gz) = 23088
diff --git a/security/ruby-password/pkg-plist b/security/ruby-password/pkg-plist
index 38b051e8c2b8..270d95e8bc9a 100644
--- a/security/ruby-password/pkg-plist
+++ b/security/ruby-password/pkg-plist
@@ -1,8 +1,14 @@
bin/pwgen
%%RUBY_SITEARCHLIBDIR%%/crack.so
%%RUBY_SITELIBDIR%%/password.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/example.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGES
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/example.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%@dirrmtry %%RUBY_EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%@dirrmtry %%RUBY_DOCDIR%%
+@dirrmtry %%RUBY_SITEARCHLIBDIR%%
+@dirrmtry %%RUBY_SITELIBDIR%%
+@dirrmtry lib/ruby/site_ruby
+@dirrmtry lib/ruby