aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-tcpwrap
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 15:52:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 15:52:32 +0000
commit2ac58308797b5b5c4dc2d01bd9c83ed839532ea9 (patch)
treeaa5dadf854566a8c29cda17a23f2a50efc40ee79 /security/ruby-tcpwrap
parent38b6dfa7f15f501af8f3807a330bbf6c588bff00 (diff)
downloadports-2ac58308797b5b5c4dc2d01bd9c83ed839532ea9.tar.gz
ports-2ac58308797b5b5c4dc2d01bd9c83ed839532ea9.zip
Notes
Diffstat (limited to 'security/ruby-tcpwrap')
-rw-r--r--security/ruby-tcpwrap/Makefile17
-rw-r--r--security/ruby-tcpwrap/pkg-plist4
2 files changed, 9 insertions, 12 deletions
diff --git a/security/ruby-tcpwrap/Makefile b/security/ruby-tcpwrap/Makefile
index 696a85a8988f..1fee3582bed3 100644
--- a/security/ruby-tcpwrap/Makefile
+++ b/security/ruby-tcpwrap/Makefile
@@ -23,22 +23,19 @@ USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
CONFIGURE_ARGS= --with-libwrap-dir=/usr \
--with-ident-dir="${LOCALBASE}"
+MAKE_ARGS= INSTALL_PROG="${INSTALL_PROGRAM}" \
+ INSTALL_DATA="${INSTALL_DATA}"
INSTALL_TARGET= site-install
DOCS_EN= README.en doc/tcpwrap.html.en
DOCS_JA= README.ja doc/tcpwrap.html.ja
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/sample/echod.rb ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS_EN} ${RUBY_MODDOCDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS_JA} ${RUBY_MODDOCDIR}/ja/
-.endif
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/echod.rb ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS_EN} ${STAGEDIR}${RUBY_MODDOCDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS_JA} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
.include <bsd.port.mk>
diff --git a/security/ruby-tcpwrap/pkg-plist b/security/ruby-tcpwrap/pkg-plist
index 82ee96ecb608..f55929f77f07 100644
--- a/security/ruby-tcpwrap/pkg-plist
+++ b/security/ruby-tcpwrap/pkg-plist
@@ -1,6 +1,6 @@
%%RUBY_SITEARCHLIBDIR%%/tcpwrap.so
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/echod.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/echod.rb
+%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/tcpwrap.html.en
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja