aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-net-ssh/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-08 00:35:19 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-08 00:35:19 +0000
commitf4c5c26085059124ee673033d1459e9432a93481 (patch)
treebacb4705ab38c36aadb8928c8c8e8abbd3bd1713 /security/rubygem-net-ssh/Makefile
parentf73f9886f433f9664256e7f163646c8c8cb31622 (diff)
Notes
Diffstat (limited to 'security/rubygem-net-ssh/Makefile')
-rw-r--r--security/rubygem-net-ssh/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/security/rubygem-net-ssh/Makefile b/security/rubygem-net-ssh/Makefile
index 5ce0166d785c..cb3b25700a93 100644
--- a/security/rubygem-net-ssh/Makefile
+++ b/security/rubygem-net-ssh/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: rubygem-net-ssh
-# Date created: 14 January 2006
-# Whom: Roderick van Domburg <r.s.a.vandomburg@student.utwente.nl>
-#
+# Created by: Roderick van Domburg <r.s.a.vandomburg@student.utwente.nl>
# $FreeBSD$
#
# Remeber to check sysutils/rubygem-chef
PORTNAME= net-ssh
-PORTVERSION= 2.1.4
+PORTVERSION= 2.2.2
PORTEPOCH= 2
CATEGORIES= security rubygems
MASTER_SITES= RG
@@ -15,15 +12,20 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Non-interactive SSH processing
-OPTIONS= PROMPT_PASSPHRASES "Prompt for passphrases on keys" On
+OPTIONS_DEFINE= PROMPT_PASSPHRASES
+PROMPT_PASSPHRASES_DESC= Prompt for passphrases on keys
OPTIONSFILE?= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
+OPTIONS_DEFAULT= PROMPT_PASSPHRASES
+
# to get RUBY_SITEARCHLIBDIR
USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.if !defined(WITHOUT_PROMPT_PASSPHRASES)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPROMPT_PASSPHRASES}
RUN_DEPENDS+= rubygem-ruby-termios>=0:${PORTSDIR}/comms/rubygem-ruby-termios
.endif