aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-nmap-parser
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-09 16:52:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-09 16:52:15 +0000
commit071613d1704bb2a58c6fc97f5bbe71239f012b86 (patch)
treec1ec7576396102eceec92821aaca8d0571bdf84e /security/rubygem-nmap-parser
parent9534b7d59a9f466ea5bce63a073707282ea5ae48 (diff)
The Nmap::Parser library provides a Ruby interface to
Nmap's scan data. It can run Nmap and parse its XML output directly from the scan, parse a file containing the XML data from a separate scan, parse a String of XML data from a scan, or parse XML data from an object via its read() method. This information is presented in an easy-to-use and intuitive fashion for storage and manipulation. WWW: http://rubynmap.sourceforge.net/ PR: ports/131516 Submitted by: Daniel Roethlisberger <daniel at roe.ch>
Notes
Notes: svn path=/head/; revision=227913
Diffstat (limited to 'security/rubygem-nmap-parser')
-rw-r--r--security/rubygem-nmap-parser/Makefile28
-rw-r--r--security/rubygem-nmap-parser/distinfo3
-rw-r--r--security/rubygem-nmap-parser/pkg-descr10
3 files changed, 41 insertions, 0 deletions
diff --git a/security/rubygem-nmap-parser/Makefile b/security/rubygem-nmap-parser/Makefile
new file mode 100644
index 000000000000..9cb3f00a600e
--- /dev/null
+++ b/security/rubygem-nmap-parser/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: rubygem-nmap-parser
+# Date created: 2009-02-09
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+
+PORTNAME= nmap-parser
+PORTVERSION= 0.3.1
+CATEGORIES= security rubygems
+MASTER_SITES= RF/gems
+
+MAINTAINER= daniel@roe.ch
+COMMENT= Ruby interface to Nmap scan data
+
+RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-nmap-parser/distinfo b/security/rubygem-nmap-parser/distinfo
new file mode 100644
index 000000000000..80ad1489fa77
--- /dev/null
+++ b/security/rubygem-nmap-parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/nmap-parser-0.3.1.gem) = c00f99b945199089f74d5b080f8b8bca
+SHA256 (rubygem/nmap-parser-0.3.1.gem) = 93a5157f510dbf8343e344ea9aa7e697274b25660a26930c75da9dcd1327ecd6
+SIZE (rubygem/nmap-parser-0.3.1.gem) = 13312
diff --git a/security/rubygem-nmap-parser/pkg-descr b/security/rubygem-nmap-parser/pkg-descr
new file mode 100644
index 000000000000..17d89b25e2be
--- /dev/null
+++ b/security/rubygem-nmap-parser/pkg-descr
@@ -0,0 +1,10 @@
+The Nmap::Parser library provides a Ruby interface to
+Nmap's scan data. It can run Nmap and parse its XML
+output directly from the scan, parse a file containing
+the XML data from a separate scan, parse a String of
+XML data from a scan, or parse XML data from an object
+via its read() method. This information is presented
+in an easy-to-use and intuitive fashion for storage
+and manipulation.
+
+WWW: http://rubynmap.sourceforge.net/