aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-rack-oauth2
diff options
context:
space:
mode:
authorMichael Moll <mmoll@FreeBSD.org>2015-05-26 18:11:32 +0000
committerMichael Moll <mmoll@FreeBSD.org>2015-05-26 18:11:32 +0000
commit68bf3ab2bbd8ce7c72017c94e270e196affd74c9 (patch)
tree95a6194a6833f4eab46452e25dffc44804987f5f /security/rubygem-rack-oauth2
parent613fce7669dfe4328eed153523adf20df978f8de (diff)
downloadports-68bf3ab2bbd8ce7c72017c94e270e196affd74c9.tar.gz
ports-68bf3ab2bbd8ce7c72017c94e270e196affd74c9.zip
Notes
Diffstat (limited to 'security/rubygem-rack-oauth2')
-rw-r--r--security/rubygem-rack-oauth2/Makefile24
-rw-r--r--security/rubygem-rack-oauth2/distinfo2
-rw-r--r--security/rubygem-rack-oauth2/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/security/rubygem-rack-oauth2/Makefile b/security/rubygem-rack-oauth2/Makefile
new file mode 100644
index 000000000000..f337732acb42
--- /dev/null
+++ b/security/rubygem-rack-oauth2/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= rack-oauth2
+PORTVERSION= 1.1.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= OAuth 2.0 Server & Client Library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activesupport>=2.3:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-attr_required>=0.0.5:${PORTSDIR}/devel/rubygem-attr_required \
+ rubygem-httpclient>=2.4:${PORTSDIR}/www/rubygem-httpclient \
+ rubygem-multi_json>=1.3.6:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-rack>=1.1:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-rack-oauth2/distinfo b/security/rubygem-rack-oauth2/distinfo
new file mode 100644
index 000000000000..5be728e3a8fc
--- /dev/null
+++ b/security/rubygem-rack-oauth2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rack-oauth2-1.1.1.gem) = 4bd6bfdb9b8044792dbff5313a343fe86ed5523d4f685c5431e55e71fefabec9
+SIZE (rubygem/rack-oauth2-1.1.1.gem) = 30208
diff --git a/security/rubygem-rack-oauth2/pkg-descr b/security/rubygem-rack-oauth2/pkg-descr
new file mode 100644
index 000000000000..1d071af619e4
--- /dev/null
+++ b/security/rubygem-rack-oauth2/pkg-descr
@@ -0,0 +1,4 @@
+OAuth 2.0 Server & Client Library.
+Both Bearer and MAC token type are supported.
+
+WWW: https://github.com/nov/rack-oauth2