aboutsummaryrefslogtreecommitdiff
path: root/security/saferpay
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-12 01:08:05 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-12 01:08:05 +0000
commitbcfb2fbd8c14a202d3b0281aa1cf64aeac5f25f3 (patch)
tree7498a01a3305bbc6ff6f8c39caf64746c27fa6aa /security/saferpay
parentd773c16349fd33b3470f32fd513de69dcae58962 (diff)
Notes
Diffstat (limited to 'security/saferpay')
-rw-r--r--security/saferpay/Makefile4
-rw-r--r--security/saferpay/files/patch-jConfigurationSetup.cpp11
-rw-r--r--security/saferpay/files/patch-jMessageFactory.cpp83
-rw-r--r--security/saferpay/files/patch-jMessageFactory.h38
-rw-r--r--security/saferpay/files/patch-jMessageObject.cpp29
-rw-r--r--security/saferpay/files/patch-jMessageObject.h12
6 files changed, 175 insertions, 2 deletions
diff --git a/security/saferpay/Makefile b/security/saferpay/Makefile
index 5243aedd7482..8fc45fb997f3 100644
--- a/security/saferpay/Makefile
+++ b/security/saferpay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= saferpay
PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.saferpay.com/download/
DISTFILES= ${PORTNAME}_${PORTVERSION}_linux-g++_src.tar.gz
@@ -49,7 +49,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
+.if ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
.endif
diff --git a/security/saferpay/files/patch-jConfigurationSetup.cpp b/security/saferpay/files/patch-jConfigurationSetup.cpp
new file mode 100644
index 000000000000..a6eff9322a3a
--- /dev/null
+++ b/security/saferpay/files/patch-jConfigurationSetup.cpp
@@ -0,0 +1,11 @@
+--- saferpay/jConfigurationSetup.cpp.orig 2008-12-19 13:13:09.000000000 +0100
++++ saferpay/jConfigurationSetup.cpp 2008-12-19 13:12:50.000000000 +0100
+@@ -33,7 +33,7 @@
+ IDP_E_UNEXPECTED)
+ return;
+ }
++ env->SetIntField(obj, fid, (jlong)CreateConfigurationSetup());
+- env->SetIntField(obj, fid, (jint)CreateConfigurationSetup());
+ }
+
+ JNIEXPORT void JNICALL Java_soplex_saferpay_ConfigurationSetup_nDestruct
diff --git a/security/saferpay/files/patch-jMessageFactory.cpp b/security/saferpay/files/patch-jMessageFactory.cpp
new file mode 100644
index 000000000000..7218e9a41128
--- /dev/null
+++ b/security/saferpay/files/patch-jMessageFactory.cpp
@@ -0,0 +1,83 @@
+--- saferpay/jMessageFactory.cpp.orig 2008-12-19 13:15:19.000000000 +0100
++++ saferpay/jMessageFactory.cpp 2008-12-19 13:13:40.000000000 +0100
+@@ -29,7 +29,7 @@
+ IDPJNI_THROW1("MessageFactory::Construct(): m_Handle != 0", IDP_E_UNEXPECTED)
+ return;
+ }
++ env->SetIntField(obj, fid, (jlong)CreateMessageFactory());
+- env->SetIntField(obj, fid, (jint)CreateMessageFactory());
+ }
+
+ JNIEXPORT void JNICALL Java_soplex_saferpay_MessageFactory_nDestruct
+@@ -40,7 +40,7 @@
+ DestroyMessageFactory(p);
+ }
+
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nVerifyPayConfirm
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nVerifyPayConfirm
+ (JNIEnv *env, jobject obj, jstring Data, jstring Signature)
+ {
+ IDPCIMPL_MessageFactory *p = 0;
+@@ -53,7 +53,7 @@
+
+ try
+ {
++ jlong r = (jlong)p->VerifyPayConfirm(mbstoSTRING(pszData), mbstoSTRING(pszSignature));
+- jint r = (jint)p->VerifyPayConfirm(mbstoSTRING(pszData), mbstoSTRING(pszSignature));
+ env->ReleaseStringUTFChars(Data, pszData);
+ env->ReleaseStringUTFChars(Signature, pszSignature);
+ return r;
+@@ -104,7 +104,7 @@
+ env->ReleaseStringUTFChars(Path, pszPath);
+ }
+
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayInit
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayInit
+ (JNIEnv *env, jobject obj)
+ {
+ IDPCIMPL_MessageFactory *p = 0;
+@@ -114,7 +114,7 @@
+
+ try
+ {
++ return (jlong)p->CreatePayInit();
+- return (jint)p->CreatePayInit();
+ }
+ catch(IDP_Exception e)
+ {
+@@ -132,7 +132,7 @@
+ }
+ }
+
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayComplete
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayComplete
+ (JNIEnv *env, jobject obj, jstring Id, jstring Token)
+ {
+ IDPCIMPL_MessageFactory *p = 0;
+@@ -145,7 +145,7 @@
+
+ try
+ {
++ jlong r = (jlong)p->CreatePayComplete(mbstoSTRING(pszId), mbstoSTRING(pszToken));
+- jint r = (jint)p->CreatePayComplete(mbstoSTRING(pszId), mbstoSTRING(pszToken));
+ env->ReleaseStringUTFChars(Id, pszId);
+ env->ReleaseStringUTFChars(Token, pszToken);
+ return r;
+@@ -168,7 +168,7 @@
+ }
+ }
+
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nCreateRequest
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nCreateRequest
+ (JNIEnv *env, jobject obj, jstring MsgType)
+ {
+ IDPCIMPL_MessageFactory *p = 0;
+@@ -180,7 +180,7 @@
+
+ try
+ {
++ jlong r = (jlong)p->CreateRequest(mbstoSTRING(pszMsgType));
+- jint r = (jint)p->CreateRequest(mbstoSTRING(pszMsgType));
+ env->ReleaseStringUTFChars(MsgType, pszMsgType);
+ return r;
+ }
diff --git a/security/saferpay/files/patch-jMessageFactory.h b/security/saferpay/files/patch-jMessageFactory.h
new file mode 100644
index 000000000000..caa16eb617b5
--- /dev/null
+++ b/security/saferpay/files/patch-jMessageFactory.h
@@ -0,0 +1,38 @@
+--- saferpay/jMessageFactory.h.orig 2008-12-19 13:15:44.000000000 +0100
++++ saferpay/jMessageFactory.h 2008-12-19 13:13:46.000000000 +0100
+@@ -12,7 +12,7 @@
+ * Method: nVerifyPayConfirm
+ * Signature: (Ljava/lang/String;Ljava/lang/String;)I
+ */
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nVerifyPayConfirm
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nVerifyPayConfirm
+ (JNIEnv *, jobject, jstring, jstring);
+
+ /*
+@@ -44,7 +44,7 @@
+ * Method: nCreatePayInit
+ * Signature: ()I
+ */
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayInit
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayInit
+ (JNIEnv *, jobject);
+
+ /*
+@@ -52,7 +52,7 @@
+ * Method: nCreatePayComplete
+ * Signature: (Ljava/lang/String;Ljava/lang/String;)I
+ */
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayComplete
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nCreatePayComplete
+ (JNIEnv *, jobject, jstring Id, jstring Token);
+
+ /*
+@@ -60,7 +60,7 @@
+ * Method: nCreateRequest
+ * Signature: (Ljava/lang/String;)I
+ */
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageFactory_nCreateRequest
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageFactory_nCreateRequest
+ (JNIEnv *env, jobject obj, jstring MsgType);
+
+ #ifdef __cplusplus
diff --git a/security/saferpay/files/patch-jMessageObject.cpp b/security/saferpay/files/patch-jMessageObject.cpp
new file mode 100644
index 000000000000..ff378eec082e
--- /dev/null
+++ b/security/saferpay/files/patch-jMessageObject.cpp
@@ -0,0 +1,29 @@
+--- saferpay/jMessageObject.cpp.orig 2008-12-19 13:17:10.000000000 +0100
++++ saferpay/jMessageObject.cpp 2008-12-19 13:16:25.000000000 +0100
+@@ -30,7 +30,7 @@
+ IDPJNI_THROW1("MessageObject::Construct(): m_Handle != 0", IDP_E_UNEXPECTED)
+ return;
+ }
++ env->SetIntField(obj, fid, (jlong)CreateMessageObject());
+- env->SetIntField(obj, fid, (jint)CreateMessageObject());
+ }
+
+ JNIEXPORT void JNICALL Java_soplex_saferpay_MessageObject_nDestruct
+@@ -169,7 +169,7 @@
+ }
+ }
+
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageObject_nExecute
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageObject_nExecute
+ (JNIEnv *env, jobject obj)
+ {
+ IDPCIMPL_MessageObject *p;
+@@ -178,7 +178,7 @@
+
+ try
+ {
++ return (jlong)p->Execute();
+- return (jint)p->Execute();
+ }
+ catch(IDP_Exception e)
+ {
diff --git a/security/saferpay/files/patch-jMessageObject.h b/security/saferpay/files/patch-jMessageObject.h
new file mode 100644
index 000000000000..49726a598436
--- /dev/null
+++ b/security/saferpay/files/patch-jMessageObject.h
@@ -0,0 +1,12 @@
+--- saferpay/jMessageObject.h.orig 2008-12-19 13:17:21.000000000 +0100
++++ saferpay/jMessageObject.h 2008-12-19 13:16:20.000000000 +0100
+@@ -52,7 +52,7 @@
+ * Method: nExecute
+ * Signature: ()I;
+ */
++JNIEXPORT jlong JNICALL Java_soplex_saferpay_MessageObject_nExecute
+-JNIEXPORT jint JNICALL Java_soplex_saferpay_MessageObject_nExecute
+ (JNIEnv *, jobject);
+
+ /*
+