aboutsummaryrefslogtreecommitdiff
path: root/security/samhain
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-08-30 22:04:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-08-30 22:04:29 +0000
commit54b77a9bfbbc331fa7dea23afcdcf4d9bd78a4d5 (patch)
treec25fc682ffd035511ea28fb5e9f3613617cda23c /security/samhain
parent16131ae1a1c77e4f8dc2c4b7e9f271dae3e48c0f (diff)
downloadports-54b77a9bfbbc331fa7dea23afcdcf4d9bd78a4d5.tar.gz
ports-54b77a9bfbbc331fa7dea23afcdcf4d9bd78a4d5.zip
Notes
Diffstat (limited to 'security/samhain')
-rw-r--r--security/samhain/Makefile33
-rw-r--r--security/samhain/distinfo4
2 files changed, 30 insertions, 7 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index def37a7a6a0f..c00ad8ca7e29 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -9,15 +9,17 @@
#
# WITH_RUNAS_USER:
# Whe building with "WITH_SERVER" defined, the username of the
-# account Yule will run as. Defaults to "yule".
+# account Yule will run as. Defaults to "yule". If using
+# WITH_GPG, ensure that this user exists and has a pgp
+# keypair before installing.
#
# WITH_LOG_SERVER, WITH_ALT_LOG_SERVER. When "WITH_CLIENT" is defined,
-# these specify what server the client will fetch configuration
+# these specify what server the client will fetch configuration
# and database files from. This can also be defined at runtime.
#
PORTNAME= samhain
-PORTVERSION= 2.0.8
+PORTVERSION= 2.0.9
CATEGORIES= security
MASTER_SITES= http://la-samhna.de/archive/ \
http://cold.darkambient.net/
@@ -30,6 +32,7 @@ OPTIONS= KCHECK "Enable rogue KLD detection" off \
GPG "Enable GnuPG support" off \
MYSQL "Enable MySQL logging" off \
POSTGRESQL "Enable PostgreSQL logging" off \
+ XML_LOGS "Enable XML-formatted logs" on \
LIBWRAP "Enable TCP wrapper support" on \
CLIENT "Build as Samhain network client" off \
SERVER "Build as Yule network server" off
@@ -44,8 +47,13 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-login-watch --localstatedir=/var \
--mandir=${PREFIX}/man --enable-suidcheck
+.if !defined(WITHOUT_XML_LOGS)
+CONFIGURE_ARGS+= --enable-xml-log
+.endif
.if defined(WITH_RUNAS_USER)
CONFIGURE_ARGS+= --enable-identity=${WITH_RUNAS_USER}
+.else
+CONFIGURE_ARGS+= --enable-identity=yule
.endif
.if defined(WITH_KCHECK)
CONFIGURE_ARGS+= --with-kcheck
@@ -56,10 +64,10 @@ CONFIGURE_ARGS+= --with-gpg=${PREFIX}/bin/gpg
.if defined(WITH_MYSQL)
CONFIGURE_ARGS+= --with-database=mysql \
--with-cflags=-I${LOCALBASE}/include/mysql \
- --with-libs=-L${LOCALBASE}/lib/mysql --enable-xml-log
+ --with-libs=-L${LOCALBASE}/lib/mysql
.endif
.if defined(WITH_POSTGRESQL)
-CONFIGURE_ARGS+= --with-database=postgresql --enable-xml-log
+CONFIGURE_ARGS+= --with-database=postgresql
.endif
.if !defined(WITHOUT_LIBWRAP)
CONFIGURE_ARGS+= --with-libwrap
@@ -117,6 +125,20 @@ pre-everything::
@${ECHO_MSG}
.endif
+.if defined(WITH_MYSQL) && !defined(WITH_XML_LOGS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "XML logging is required to log to MySQL."
+ @${ECHO_MSG}
+.error "XML logging is required to log to MySQL."
+.endif
+
+.if defined(WITH_POSTGRESQL) && !defined(WITH_XML_LOGS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "XML logging is required to log to Postgres."
+ @${ECHO_MSG}
+.error "XML logging is required to log to Postgres."
+.endif
+
post-extract:
@${TAR} -C ${WRKDIR} -xzf ${WRKSRC}.tar.gz
@${RM} ${WRKSRC}.tar.gz ${WRKSRC}.tar.gz.asc
@@ -125,6 +147,7 @@ post-install:
.if !defined(WITH_SERVER)
@${CP} ${WRKSRC}/init/samhain.startFreeBSD ${PREFIX}/etc/rc.d/samhain.sh.sample
@${CP} ${WRKSRC}/samhainrc ${PREFIX}/etc/samhainrc.sample
+ @${CHGRP} wheel ${PREFIX}/etc/samhainrc.sample
.else
@${CP} ${WRKSRC}/init/samhain.startFreeBSD ${PREFIX}/etc/rc.d/yule.sh.sample
@${CP} ${WRKSRC}/yulerc ${PREFIX}/etc/yulerc.sample
diff --git a/security/samhain/distinfo b/security/samhain/distinfo
index f0a11d160dc6..54990c82c220 100644
--- a/security/samhain/distinfo
+++ b/security/samhain/distinfo
@@ -1,2 +1,2 @@
-MD5 (samhain_signed-2.0.8.tar.gz) = 2364ae24f381a658db0f3be96cedabc4
-SIZE (samhain_signed-2.0.8.tar.gz) = 1194062
+MD5 (samhain_signed-2.0.9.tar.gz) = 48985d91400db746f1513fc332edb704
+SIZE (samhain_signed-2.0.9.tar.gz) = 1210510