aboutsummaryrefslogtreecommitdiff
path: root/security/sasp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /security/sasp
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
Notes
Diffstat (limited to 'security/sasp')
-rw-r--r--security/sasp/Makefile5
-rw-r--r--security/sasp/files/patch-Makefile11
2 files changed, 15 insertions, 1 deletions
diff --git a/security/sasp/Makefile b/security/sasp/Makefile
index ebe373c6e3bc..09496e5b92a3 100644
--- a/security/sasp/Makefile
+++ b/security/sasp/Makefile
@@ -16,9 +16,12 @@ MASTER_SITE_SUBDIR= ahze
MAINTAINER= sviat@OpenGEEKS.it
COMMENT= A tool that permits to use a gateway whatever IP we have
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
NO_WRKSUBDIR= yes
+MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
PLIST_FILES= sbin/sasp
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
.include <bsd.port.mk>
diff --git a/security/sasp/files/patch-Makefile b/security/sasp/files/patch-Makefile
new file mode 100644
index 000000000000..7ec25d4b7c98
--- /dev/null
+++ b/security/sasp/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- ./Makefile.orig Thu Apr 7 06:33:45 2005
++++ ./Makefile Wed Sep 27 22:46:49 2006
+@@ -1,6 +1,6 @@
+ all:
+- cc -o sasp sasp.c -L/usr/local/lib -I/usr/local/include -lpcap -lnet
++ ${CC} `${LIBNET_CONFIG} --cflags` -o sasp sasp.c -lpcap `${LIBNET_CONFIG} --libs`
+ install:
+- install -o root -m 555 sasp /usr/local/sbin
++ ${BSD_INSTALL_PROGRAM} sasp ${PREFIX}/sbin
+ clean:
+ rm -rf *.o